Kodi Community Forum

Full Version: Being blocked on wiki
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

When asking about this I was referred to this forum, therefore I opened this thread.
I recently created a wiki account and made two edits with stuff I learned while setting up kodi and considered worth adding. However I now wanted to edit http://kodi.wiki/index.php?title=MySQL/Advanced_notes but clicking on "show preview" and the like firefox reports that I have been blocked by kodi.wiki. Why is that happening?
Thread moved to the wiki section
As far as I can tell, your account isn't blocked: http://kodi.wiki/index.php?title=Special...%3AImsodin

There were some old IP bans that I've just undone, just in case there was any overlap. Can you try it again? If it still says you're blocked, tell us what the message says and if it is from the wiki itself or from CloudFlare.
Oh wait, it's saying I'm blocked too. lol. It's a CloudFlare block. I'll look into it.
It's a false positive on the text on the page.


where [dot] is . and that triggers CloudFlare protection (including the forum). I've created a work-around so that the page can be edited. Basically /etc/mysql/my{{dot}}cnf can be used and will render the correct text, without triggering anything. You should be able to edit that page again.
Thanks for the quick help, I did not notice it earlier as mail notifications didn't arrive, I must have misconfigured something.
I just did the edit, it worked fine.

One question: Is it common here to add something like [sovled] to the thread title when the problem is solved (did not find anything on that in the rules)?
Fairly common :)
I should have just tried it out, there is even a menu in place to do this xD
I just wanted to make an update on
and have been blocked the same way again...
I can't seem to trigger the block. What was it you were trying to add?
This sentence
"The playlists should be placed into a folder named "music", "mixed" or "video" in the following location:"
in front of the playlist locations, not even a link.
It looks like it's matching this

"WORD" or "WORD" in WORD

At this point Cloudflare is defeating the point of having a wiki. Can the word filter be disabled on the wiki? That was never an issue there.
If you throw an extra comma in there it should work, like

music", "mixed", or "video"

I don't know if that is grammatically correct, but it will do for now.
Thanks for your help. The problem seemed to be the kind of " symbol used. I now inserted them using the wiki GUI which did not trigger the filter.
This is really silly though and not very contribution friendly, so I suggest fixing or disabling this.