Kodi Community Forum

Full Version: 3D video files not playing with split screen
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
A few of my 3D files on my hard drive are not playing as they should in split screen, they are only playing as normal 2D movies. However If I play them on my computer using any standard video player such as mpc I see the split screen.

Because these files in particular are not playing in their native split screen, it would be useless to select the tv 3D side-by-side or over-under mode; it would look messy . For some reason kodi is interpreting them as 2D only.

Why is kodi playing some of these 3D video files as 2D and ignoring their split screen?

My normal 3D files plays with the split screen, from there I can just use my tv remote and select 3D mode then choose SBS or OU.

I am using the Nvidia shield tv 16gb model, and my hard drive is connected to the shield through usb.
So the videos are encoded HSBS?

How are they named?
(2016-06-13, 04:55)nickr Wrote: [ -> ]So the videos are encoded HSBS?

How are they named?

The are all named the right way. All my SBS are named "Half-SBS", and all my over under are named 3D.HOU. Two HSBS and one HOU are giving problems.

What do you mean when you say encoded HSBS? Would that mean these video files are not encoded properly?
I guess its debug log (wiki) time.
I have found the solution.

Go to acceleration in video settings: settings > video > acceleration
Then do the following: Disable "enable hardware acceleration"

This should fix it. Now all my 3D videos plays with the split screen. I really do not know why this works but it works!