Kodi Community Forum

Full Version: Bluray iso utils - Full support of blu-ray images in Kodi
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I have some difficulties enabling this script/addon, please find the debug log below:

LibreELEC release: Generic.x86_64-7.95.3
Kodi (17.0 Git:a10c504). Platform: Linux x86 64-bit

14:35:13.560 T:140003887789824    INFO: initializing python engine.
14:35:13.560 T:140003887789824   DEBUG: CPythonInvoker(10, /storage/.kodi/addons/service.bluray_iso_utils/service.py): start processing
14:35:13.570 T:140003887789824   DEBUG: -->Python Interpreter Initialized<--
14:35:13.570 T:140003887789824   DEBUG: CPythonInvoker(10, /storage/.kodi/addons/service.bluray_iso_utils/service.py): the source file to load is "/storage/.kodi/addons/service.bluray_iso_utils/service.py"
14:35:13.570 T:140003887789824   DEBUG: CPythonInvoker(10, /storage/.kodi/addons/service.bluray_iso_utils/service.py): setting the Python path to /storage/.kodi/addons/service.bluray_iso_utils:/storage/.kodi/addons/script.module.bottle/lib:/storage/.kodi/addons/script.module.web-pdb/libs:/usr/lib/python27.zip:/usr/lib/python2.7:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/lib/python2.7/site-packages:/usr/lib/python2.7/site-packages/gtk-2.0
14:35:13.570 T:140003887789824   DEBUG: CPythonInvoker(10, /storage/.kodi/addons/service.bluray_iso_utils/service.py): entering source directory /storage/.kodi/addons/service.bluray_iso_utils
14:35:13.570 T:140003887789824   DEBUG: CPythonInvoker(10, /storage/.kodi/addons/service.bluray_iso_utils/service.py): instantiating addon using automatically obtained id of "service.bluray_iso_utils" dependent on version 2.24.0 of the xbmc.python api
14:35:13.605 T:140003887789824   DEBUG: Bluray iso utils: version 0.2.0 started
14:35:13.607 T:140003887789824   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.UnboundLocalError'>
                                            Error Contents: local variable 'sqlcon_wl' referenced before assignment
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/service.bluray_iso_utils/service.py", line 962, in <module>
                                                main = Main()
                                              File "/storage/.kodi/addons/service.bluray_iso_utils/service.py", line 883, in __init__
                                              File "/storage/.kodi/addons/service.bluray_iso_utils/service.py", line 933, in _init_vars
                                            UnboundLocalError: local variable 'sqlcon_wl' referenced before assignment
                                            -->End of Python script error report<--
14:35:13.663 T:140005643856000   DEBUG: CGUIMediaWindow::GetDirectory (addons://)
14:35:13.663 T:140005643856000   DEBUG:   ParentPath = []
14:35:13.686 T:140003896182528   DEBUG: CAddonMgr::GetAvailableUpdates took 22 ms
14:35:13.688 T:140003887789824    INFO: Python script stopped
I get same error as on pg 1 -
couldnt post full log - too big - posted from where install begins

I'll try to reproduce the error (and fix it).
Version 0.2.1 is released on github.

Install error is fixed, was some indentation error.

Let me know it it works now.
ok seems to have installed correctly

here is the log http://pastebin.com/mhXcadXs

I have debug mode on.

I have set up one folder in the format- but it did not play correctly
Hi Jpil,

I see nothing in the log that indicates you tried to play a .strm file (or more correctly, the addon didn't notice it).

Please post the name and contents of the .strm file.
Please post the contents of the BIUinfo.xml file.

(2017-02-19, 18:52)Wimpie Wrote: [ -> ]Hi Jpil,

I see nothing in the log that indicates you tried to play a .strm file (or more correctly, the addon didn't notice it).

Please post the name and contents of the .strm file.
Please post the contents of the BIUinfo.xml file.

I wasnt playing strm files - for some reason they do not work - you tried helping me with that in another thread . I pretty much gave up on getting it to work - so tried your addon.
I am using dummy mp4 files labled : s09e01.mp4 through s09e012.mp4

here is my biuinfo.xml:

edit - sorry just read the instructions a little better - fixed the naming error -

per log have error somewhere in the xml file

latest log http://pastebin.com/Y8MD6131

line 2507 : DEBUG: Bluray iso utils: BIUfile.xml = smb://TOWER/TV/doctor who (2005)/series 9/BIUinfo.xml
line 2508 : DEBUG: Bluray iso utils: Error reading BIUfile.xml!!

Means either the BIUinfo.xml file isn't there, or the contents is not correct.

Please post the BIUinfo.xml file.
ok I thought I had it all correct :
here is latest log

here is the xml file

I know that I have to correct the file pointers for ep 2 and beyond . I have been working to make sure ep 1 works .

file structure :
series 9
.biufile ( folder )


dummy files
Your BIUinfo.xml file is not correct.

It misses the "</directorydetails>".

Let's leave the other episodes out for moment. Fill the "BIUinfo.xml" with what is only needed for s09e01.

<?xml version="1.0" encoding="utf-8"?>
  <video filename="s09e01.BIUvideo.mp4">

PS: you can check if the xml is valid by using a xml validator.
this is why having someone check your code is a good thing
ok that changed nothing.
I assume that the file call to the xml file assumes it is in the same directory as the dummy files. fyi I am using a nas - I assume you picked that up from the log file.
2nd - is it possible that my av ( defender) is causing the problem?
becuse those are the only things I can think of -
the file names are correct - I copied/pasted from the file/folder names. so they match what is in the xml file.
Do you have this directory layout? (you don't need the copy of the BIUinfo.xml file ofcourse.)


I also have a NAS (unraid). Should be no problem, only difference is that I use drive letter (mapping inside windows) instead.

Don't know about the virus protector. Switch it off to test if it is a problem.
ok - is the storage location biufile, or biufiles?
in the xml you call it biufile, your example above you call it biufiles....
The screenshot is correct. I did a copy/paste of your pastebin file with the "</directorydetails>" line added. I didn't notice the directory wasn't correct (= now fixed).

The directory is called ".BIUfiles" (in windows ".BIUfiles.", trailing "." gets dropped).
Pages: 1 2 3