Kodi Community Forum

Full Version: WeTek Hub - 24p HD Netflix - HD Kodi Audio - 10bit HEVC - Lollipop - 4K
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Someone tried Google Chrome with the hub?
Mine will freeze and after longer time crash to launcher...
Is there any better browser than the aosp for dpad use?

And maybe even a better keyboard? The leanback one makes it look better, but I like the fire tv one, is there something like that (even possible)?
I always use the leanback keyboard but since some users prefer to "touch" the keys with a mouse (and the leanback does not have an onClick/onTouch listener), the AOSP one is the default.

About Chrome, I think it is eating the device ram and gets self killed by the lowmemorykiller. Next week there will be an OTA, I have changed a bit the ram management, hopefully it will behave better also with Chrome (the tweaked Netflix Android TV works after this modification for example)
So i just got my wetek hub 2 days ago now and have been fiddling with it ever sense...

normal play store hulu app doesnt work for playback.
android tv version does work rather well

netflix play store versions smooth playback at 1080p (no 4k for me yet). however the app navigation is atrocious.
Netflix android tv app that was modified to work for the wetek core (works kindof) it appears that it doesnt use hardware decoding so the cpu dies and cant handle the stream very well... ( tested with developer options enabled and gpu bar graph with apps opened). the UI from the android tv versions is much easier to navigate than the stock android app with the silly remote. If only we could enable hardware decoding in the android tv app... anytakers?

kodi 16.1 from the playstore works great so far with my content (1080p) stuff as i don't have a 4k tv yet...
It is not that the issue of Netflix Android TV, I already fixed it and will be included in the upcoming OTA scheduled for the beginning of the next week Wink
@chris
Thx for your answere.
I first notice this problem at stresming from my Server with kodi. Then I checked with speedtest.com my internetconnection. Download only 10 Mbit. Connected with my Wlan: download 75Mbit. Also with a notebook at the same ethernet cable 75 Mbit.
So I suggest, that there is problem with my ethernet port.
Yes I can confirm the tweaked version of Netflix (leanback) for Android TV that the Core owners enjoy now works with the soon to be released OTA Firmware update on the Hub. Smile
I'm glad to see the back of the regular Google Play store Netflix app to be honest. It was unusable for me with the Hub's D-Pad remote control
(2016-07-23, 19:02)jb1977 Wrote: [ -> ]@chris
Thx for your answere.
I first notice this problem at stresming from my Server with kodi. Then I checked with speedtest.com my internetconnection. Download only 10 Mbit. Connected with my Wlan: download 75Mbit. Also with a notebook at the same ethernet cable 75 Mbit.
So I suggest, that there is problem with my ethernet port.

If you want to get your hands dirty you can just connect to the hub by ftp and copy that iperf3 file to a path like /data/misc, then from telnet "chmod 755 /data/misc/iperf3" and start it with "/data/misc/iperf3 -s".
At this point you can run iperf3 from a PC connected by ethernet with "iperf3 -c hub_ip" and "iperf3 -c hub_ip --reverse" to test both way (as server and as client)

Code:
[email protected]:/ # /data/misc/iperf3 -s                                        
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
Accepted connection from 192.168.69.90, port 39764
[  5] local 192.168.69.240 port 5201 connected to 192.168.69.90 port 39766
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-1.00   sec   109 MBytes   910 Mbits/sec                  
[  5]   1.00-2.00   sec   112 MBytes   940 Mbits/sec                  
[  5]   2.00-3.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   3.00-4.00   sec   112 MBytes   942 Mbits/sec                  
[  5]   4.00-5.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   5.00-6.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   6.00-7.00   sec   112 MBytes   942 Mbits/sec                  
[  5]   7.00-8.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   8.00-9.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   9.00-10.00  sec   112 MBytes   941 Mbits/sec                  
[  5]  10.00-10.01  sec  1.06 MBytes   882 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  5]   0.00-10.01  sec  1.09 GBytes   939 Mbits/sec    0             sender
[  5]   0.00-10.01  sec  1.09 GBytes   938 Mbits/sec                  receiver
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
Accepted connection from 192.168.69.90, port 41056
[  5] local 192.168.69.240 port 5201 connected to 192.168.69.90 port 41058
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-1.00   sec  77.0 MBytes   646 Mbits/sec                  
[  5]   1.00-2.00   sec  63.9 MBytes   536 Mbits/sec                  
[  5]   2.00-3.00   sec  64.6 MBytes   542 Mbits/sec                  
[  5]   3.00-4.00   sec  72.6 MBytes   609 Mbits/sec                  
[  5]   4.00-5.00   sec  73.0 MBytes   612 Mbits/sec                  
[  5]   5.00-6.00   sec  73.7 MBytes   618 Mbits/sec                  
[  5]   6.00-7.00   sec  49.3 MBytes   414 Mbits/sec                  
[  5]   7.00-8.00   sec  64.6 MBytes   541 Mbits/sec                  
[  5]   8.00-9.00   sec  62.9 MBytes   527 Mbits/sec                  
[  5]   9.00-10.00  sec  60.3 MBytes   507 Mbits/sec                  
[  5]  10.00-10.02  sec   724 KBytes   302 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-10.02  sec   663 MBytes   555 Mbits/sec                  sender
[  5]   0.00-10.02  sec   662 MBytes   554 Mbits/sec                  receiver

This is my result (second run is --reverse)
(2016-07-23, 18:29)ChristianTroy Wrote: [ -> ]About Chrome, I think it is eating the device ram and gets self killed by the lowmemorykiller. Next week there will be an OTA, I have changed a bit the ram management, hopefully it will behave better also with Chrome (the tweaked Netflix Android TV works after this modification for example)

I have just tried Chrome (I am running the future firmware btw) and it was working alright, I also tried browsing an heavy news website (www.corriere.it) and worked good, I think that the new OTA will fix your issue
Thanks for the Info! Smile
But you don't know a "real" leanback browser too?
I searched a little and only found a old version of dolphine browser (I don't want to use) ...
(2016-07-23, 18:58)ChristianTroy Wrote: [ -> ]It is not that the issue of Netflix Android TV, I already fixed it and will be included in the upcoming OTA scheduled for the beginning of the next week Wink

Awesome! can't wait. I think i have a pretty usable device at the moment just the way i want it short of netflix.
@Stimmenhotel
There should be a version of Opera packed with Sony Android TV devices but I really don't like it very much... http://www.apkmirror.com/apk/opera-softw...-download/
For browsing I always use the trusted K400 keyboard + touchpad (and Firefox)
Has anyone got PCM Multichannel out of their Hub using LibreElec? In wrxtasy's post he reports that hdmkv confirmed PCM multichannel in LibreElec - but whichever build I try I only get PCM 2.0 output when I play multichannel (DD, DTS, AAC, DTS HD, True HD etc.) with passthrough / bit streaming disabled. (This is a useful feature if you have FLAC or AAC multichannel and want to avoid transcoding to Dolby 5.1)
@ChristianTroy

Thanks, I will look into opera.
But I think I will use Chrome with my air mouse Smile

One more thing...
I wanted to update libreelec and my sd card is stuck inside the sd card slot ... isn't there any mechanics for easy removing? oO
Nevermind: I haven't pushed deep enough the last time .. Smile
I cut my finger nails pretty often Big Grin and I feel your pain when trying to remove the microsd card, I just use another microsd card to insert in the hole until it clicks
I have a grapical glitch.
On the right side of the screen I see a few pixels from the lift side.
On the left side these pixels are "behind the border" of the screen.
The picture seems to be moved a few pixels to the left and the cutted part returns on the right side again.,

How can I fix this? (In Android and in libreelec the same)