Kodi Community Forum

Full Version: WeTek Hub - 24p HD Netflix - HD Kodi Audio - 10bit HEVC - Lollipop - 4K
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Question..

Is there a list of maybe what fixes are being worked on if any for Android and LibreELEC? That way I don't need to bring up anything if its already been brought up? I didn't see or probably missed this info on the Wetek forums.
(2016-08-12, 18:43)wesk05 Wrote: [ -> ]Can one of you check whether this HEVC Anime plays correctly on the Hub? It doesn't work on the Minix U1 or Odroid C2 (video freezes/audio continues). It does play correctly on the Shield and a S905X box.

Dragon Ball Super

Disclaimer: I didn't upload the video.

It plays perfectly for me using Android, but only if I disable AMLogic codec and let mediacodec handle it. This means LibreELEC will have issues since they need the AMLogic codec for hardware decoding (for now).
(2016-08-13, 05:35)Ned Scott Wrote: [ -> ]It plays perfectly for me using Android, but only if I disable AMLogic codec and let mediacodec handle it. This means LibreELEC will have issues since they need the AMLogic codec for hardware decoding (for now).
Thanks for testing. I didn't think of disabling amcodec. It does play on the Minix U1 when amcodec is disabled and you are right, it doesn't play in LibreELEC. So, it looks like an issue with amcodec. That also explains why it played correctly on the S905X box with Kodi 17 alpha 3.
Issue with DTS-HD MA playback using Wetek Media Player.
DTS-HD MA audio works with audio passthrough enabled only at 60Hz playback.
Regular DTS and Dolby are working correctly using passthrough audio at 60Hz and 24Hz playback.

If I change WMP to adjust display frame rate to 'always" or "start/stop", there is no audio passed to my AVR (no DTS-HD MA logo) at 24Hz playback.
I've tried all combinations of Level1 or 2 and adding WMP to display refresh rate app.

i can provide logs if requested.

Edit:
I can get 24Hz playback with DTS-HD MA audio if I select Level 2 in Wetek display settings and don't add WMP to the display refresh rate app or enable "adjust display frame rate" setting in WMP.
I think I'm going to go for a Wetek Hub, but wondering if there's any voucher codes for them at the minute to save a few dollars, or if i can buy it through the kodi foundation to support the project?
So, installed wxrtasy's LibreELEC just now.

Problem: The network speed seems to be really, really slow, buffering a movie takes 10-20s. Connected via Ethernet to my NAS, not WiFi. Works much better in the Wetek OS, but still rather slow compared to my HTPC.

Another thing I noticed: The scrolling through my (small) Movie library is kind of slow in both versions. It looks like my locally stored movie information/jpegs are not scaled down. They look like very high resolution jpegs (which they are) displayed in a smaller size. Different to the Kodi on my HTPC.

Thanks for any advice!
(2016-08-20, 15:42)hayabusi Wrote: [ -> ]So, installed wxrtasy's LibreELEC just now.

Problem: The network speed seems to be really, really slow, buffering a movie takes 10-20s. Connected via Ethernet to my NAS, not WiFi. Works much better in the Wetek OS, but still rather slow compared to my HTPC.

Another thing I noticed: The scrolling through my (small) Movie library is kind of slow in both versions. It looks like my locally stored movie information/jpegs are not scaled down. They look like very high resolution jpegs (which they are) displayed in a smaller size. Different to the Kodi on my HTPC.

Thanks for any advice!
I got mine replaced for exact same reason. Check one of my previous posts here. Appalling down link speed on ethernet. Now on holiday so I can't test if the replacement is any better. I hope so or it goes back for good. Will have news in a week or so.
After a shutdown and reboot I think it works much better now, will also investigate further.
Had the same problem with my HUB (one of the first ones shipped) and I had to send it back for an exchanged one.

Seems like there is a handshake problem at the port. Others reported that when you force a 100 mbit connection via the router, then speed gets better. I didnĀ“t experience that, so I asked WeTeK for a replacement.
The new one has yet to arrive, so I cannot say if it got better.
Anyone know if there a 4k netflix app that will work on a nexbox A5 its running Android M with a 905x
Already answered in the last paragraph of this post:
http://forum.kodi.tv/showthread.php?tid=...pid2192163

Basically It's not about the Netflix App or the flavor of Android. But Netflix approval and DRM. NONE of the cheap Android boxes from Asia will likely ever meet these requirements.
So there is know way to mod the apk to allow it to play
I have been researching a suitable device for me - I have found out that an intel NUC might be an overkill for my needs and ended up reading about android boxes. I apologize in advance for my naive question, but since I have zero experience with them (and very little experience with android itself - had a windows mobile phone till 2015) here goes...

Will this tiny box play HEVC 10bit 1080p content smoothly over WiFi?

I plan to use WeTec HUB for outdoor vieweing (terrace, next to house), using a 1080p projector and some mediocre 2.0 or 2.1 or soundbar speakers. The content is on a NAS (with all KODI extra files... posters, thumbs, nfos... all stored locally as well). I did read it downsamples it to 8bit viewing, which isn't an issue (outdoorsy viewing...).
It's possible, depending on the bitrate of the file and the network. However, it's also possible for 1080P HEVC files to be made that max out the wifi.

Honestly, the Nvidia Shield is the only HEVC-capable box that I've seen that also includes the wifi to handle crazy big files. However, even then, it still depends on the bitrate.