Kodi Community Forum

Full Version: WeTek Hub - 24p HD Netflix - HD Kodi Audio - 10bit HEVC - Lollipop - 4K
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Yes, it seems that Wetek is taking a more conservative path regarding new products, since the Play 2S fiasco.
Also, they seem to have bought/created/whatever new companies as part of the Wetek which seem to be developing other devices to a more of a business perspective, selling to a more business oriented rather to the end-user. this could explain the latest lack of development for their products in the market. But who knows, I'm just "thinking out loud".

I'm satisfied with my wetek device, as it fulfills my needs,(it is not perfect, don't get me wrong) but I'm kind of a cheapskate, so I don't want to be upgrading devices every year.
Until HDR becomes a must have I will stay as I am regarding entertainment.
(2018-05-28, 19:03)christoofar Wrote: [ -> ]After having a Hub over the weekend, my impressions are mostly quite favorable. The remote is really poor, though the IR extender cable does help some. Android on this box is pretty much useless, even after the MM update, GUI is clunky, and I have not had any luck getting Netflix to run. Tried a Ninja build from apkmirror (which just errors out) and another from the App store, which runs, but doesn't play anything (just get a black screen)
However where it shines is running Libreelec, everything plays, audio is (finally) being decoded correctly, and it is pretty snappy considering the 1GB RAM. Tried like hell to get SMB2 shares working, numerous online guides wiki etc, finally gave up & reverted back to SMB1 and all is well. While I'm disappointed as the Hub doesn't seem to be able to solve my "one box to do it all" quest, I can live with a solid Kodi box, and FireTV for streaming NF & Prime.
  How do you revert back to SMB1?
Seems my Hub is having hardware issues, has started dropping video + audio when watching movies, and audio dropouts when listening to music. Wiped the SD card & started over again. Played exactly 2 movies flawlessly, now getting this grid pattern across the entire screen, and loud digital noise pulsing. Wonder if I can still return this...
last version of prime video 4.7.9 https://goo.gl/yj1KBa  ( Ultra/HD and audio 5.1 ) work Android TV v2.4.1 rom ?
thanks.
Gave up on the Hub, sent it back. Got a ShieldTV. Much better now.
(2018-06-28, 23:01)christoofar Wrote: [ -> ]Gave up on the Hub, sent it back. Got a ShieldTV. Much better now.
 i have done different question and i don't like shield.
(2018-05-29, 15:09)tredman Wrote: [ -> ]On CoreElec.

You just need Kodi Leia, input stream enabled and the netflix and prime addons.

It's not as good as the android apps, but are pretty relaible. 
What version do you use please ?
Starting to get playback problems.

Some video files get slight judder, like the player can't keep up. Audio is fine but not the video.
I'm wondering if anyone can help with a relatively minor issue I'm having. More a question than anything.
Current setup is hub connected to a denon receiver, which in turn is connected to an oldish (2010?) panasonic plasma, all via HDMI (1.4).
Hub is connected to home network via gigabit/ethernet to a QNAP NAS for local video storage.
Hub has been flashed with Ricardo's 2.4.1 ROM

Generally it has worked extremely well and adequate for my needs. Using Kodi 17.6 and modified video cache. The problem I'm having is that any movie on the network more than about 20gb in size, has constant stuttering and makes it unwatcheable. Movies are all stored as 1080p etc (no 4k/hdr etc) and play just fine when at lower file sizes, just no good when they are larger.

I initially thought this may have been due to only having 1gb of memory, but now I'm not so sure. 

I was playing around with some Kodi settings today and changed the ''allow hardware acceleration'' options in video processing. I had both 'media codec'and ''media codec (surface)' switched on. When I switched them off, I could suddenly watch a large movie (30gb that had previously not played properly), with absolutely no issues.

To me that doesn't make sense. Shouldn't I want hardware acceleration? Or am I doing something wrong (quite possible Undecided ).

Thank in advance,
HJ
@theburgersarebetter: I guess the answer to that is very sinple but you will not like it. if softwaredecoding is working and hw accel is bot, then it is a bad encoded file usualky, at least from my experience.

Regards
Vlaves
But every file above a certain size is affected? Possible, but it doesn't make sense to me
(2018-09-17, 22:34)theburgersarebetter Wrote: [ -> ]But every file above a certain size is affected? Possible, but it doesn't make sense to me

Hmm, remember having similar issues on Android. What is your Nas/Server/Fileshare protocol?
Any chance its a Win Machine with DrivePool from Stablebit? There is a Option to increase Network read speed within DrivePool, if this is your case.
Lol, that is well above my techno language skills.
Here is what I think is the answer to your questions?
Nas is QNAP, filesystem is ext3. Connected to kodi via NFS.

It does not have an issue streaming the 30gb file to a windows laptop via wifi or ethernet.
Just the wetek.

Thanks for your help
To anyone playing along at home....

I tried a bunch of different, large file size mkv's today with both hardware acceleration options on.

They worked....

@Vlaves , I think you were bang on the money with the badly encoded file, thank you!

I'm going to try and re-rip the discs to see if I can get them to work.

Thanks again
Ok smart people.
I have another issue that is not really an issue. More just something I've noticed and am curious why.
I'm no longer having the issues playing 1080p videos with large file sizes (40gb+) from above.

Keep in mind, the hub is connected to an AVR with 4k passthrough to a 1080p tv (ie not 4K), and everything via HDMI.
Kodi is set to 1080p @60Hz and auto refresh rate.
I tried playing a 4K video, just to see what would happen. The video plays, but it is constantly stuttering. I don't think it's judder, more like if the tv had a strobe effect (ie constantly dropping frames), if that makes sense. 
If I change the kodi output settings from refresh rate of 60Hz to 23.98Hz, the same video then plays smooth like butter. But the kicker is, changing it back to 60Hz, it  will continue to play smooth like butter.
Even just logging in through the kodi web interface, not changing any of the settings, (output still 1080p @60Hz), but just clicking save, and the video will play perfectly smooth.

Anyone have any ideas why? As I said, I'm not concerned as my setup is not 4k (yet).
More just wondering.

Cheers, tbab