Kodi Community Forum

Full Version: Disabling onboard RPi3 wifi running LibreELEC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm running numerous RPi3's all running LibreELEC 7.0.2 and Edimax EW-7811UTC 5G dongles via wlan1 on a 5ghz wifi network. Problem is that the onboard wifi on wlan0 randomly tries to override the dongle and find its own (non existent) connection and dropping wlan1 out. Is there anyway I can disable the onboard wifi baring in mind I am solely running LibreELEC? Thank you.
Try creating a blacklist.

Create the file /etc/modprobe.d/raspi3-blacklist.conf by adding the following entries:
blacklist brcmfmac
blacklist brcmutil
blacklist btbcm
blacklist hci_uart

If you want Bluetooth, don't include the last 3 lines.
Thanks Millhouse. Can I input all that at once via SSH? Or separate lines?
(2016-07-02, 16:33)nickrob84 Wrote: [ -> ]Thanks Millhouse. Can I input all that at once via SSH? Or separate lines?

Not sure what you mean, use "nano" or "vi" to edit "/etc/modprobe.d/raspi3-blacklist.conf" then enter the lines you need. Save the file. Reboot, and your onboard WiFi (and/or BT) should be disabled.
I know what you mean now, sorry am still fairly new to all this. Appreciate your help once again.

Apologies Millhouse - I know your dealing with an idiot here but from the point in the picture I want to (^O) write out then reboot?
Or: ctrl-x, y, return
Thank you.