Kodi Community Forum

Full Version: KeyMap help
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am having problems with the KeyMap addin. I'm attempting to map a key to "delete" so I can delete files from my video file list. The remapping seems to do nothing and the key on my remote seems to maintain its original functionality. I've tried multiple keys and restarting Kodi. Any help would be appreciated. Thx.
There should be no.need to remap a key for this to function.
Just make sure you enable delete permission from whitin basic kodi settings and delete files by using the context menu (default 'c' or longpress OK)
Thanks for the reply. This is for a home theater system and I'd prefer not to use the keyboard and use a universal remote instead. I tried the long keypress on OK, but it only responded as a short press on both my universal remote and my windows remote.
Longpress is introduced in v16. By default when longpressing a title you should be presented by a context menu, showing a delete option. Which version are you using..?
Using V.16.1. Longpressing OK doesn't work. It plays the video like a short press. All I can figure is neither of my remotes send long presses.
But surely your remote has a context menu button ?
It has a "Menu" button which does nothing.
Well fix that then.
Its fairly easy to reassign context function by using the keymap editor addon.

Just select the context menu function and press the menu button to assign it. Do not forget to save the changes.
It should work right away.. If it still doesn't could you describe the steps you do exactly so we can figure out where things go wrong.
Still think its strange that longpress does not work for you.
I have setup dozens of systems with all kinds of remotes. Longpress never fails.