Kodi Community Forum

Full Version: Gamepad isn't working in game, Kodi responds as if was video
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, new to retroplayer. I did the following

  1. Downloaded latest krypton build and installed it
  2. configured some paths to my roms (gba, snes, nes)
  3. went to settings / games / input / configured attach controllers
  4. configured my control (ds4 via bluetooth and also tried xbox one wireless) for kodi, game boy advanced, nes, snes
  5. went back to "Games" on the main menu
  6. opened my rom folder
  7. selected a game then the emulator (tried all of them, for gba, snes and nes)
  8. pushed a button on my controller, kodi treated it like a video, e.g y exited fullscreen, a bought up the hud, b exited, etc

I'm sure its something obvious I'm doing wrong, but couldnt find it mentioned in the documentation or on the forum, anyone know how to fix this?

System: Windows 10
A log of you trying to play would be helpful.

http://kodi.wiki/view/Log_file/Easy
Indeed, please post a log file. This will let me see why button presses are being sent to Kodi instead of the game.