Kodi Community Forum

Full Version: xbox one controller not working in b1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I wanted to test out the rumble stuff so I plugged in my Xbox One controller and it wasn't able to control anything. I even tried running the "configure the attached controllers" thing in settings, and pressing A on my controller didn't register. Here's the log.

http://pastebin.com/Fj0EcBE0

edit: Also, maybe needless to say, I didn't get any rumble. Running in Windows 10.
Did you update from previous v16?

If coming from v16, only a clean install will make the controller work.
If that's true, that's a major, major bug. But just for the sake of it, I've gone ahead and done a clean install and no change.
I can't control anything with the latest Milhouse Build #2108, too (Logitech Gamepad)

Downgrading to #1408 helps (tested only #1908, which didn't work also)

If you need a debug-log from #2108, pls let me know
Oh I see, so it s probably a new bug,
It doesn't work with #2208 (udev support and game controller 1.2) also
My Ps3 controller stopped working as well, same problem, no reactions at all through controller.
KodiSetup-20160814-961d012-master was the last build that worked with my controller (xbox one). Anything higher seems to not work
KodiSetup-20160816-fe8558d-master.exe is what I'm running now and it seems to work on Windows 10.
We're strangling him with a wired xbox controller to get it fixed Wink
If you need a whip, let me know.
PR10309 should fix the issue
In short install tomorrow's nightly version