Kodi Community Forum

Full Version: Compile error latest SVN
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
For some reason. after a svn update I can't compile anymore http://forum.xbmc.org/images/smilies2/no6xn.gif
No

I'm running Ubuntu 7.04 and followed the README.linux (Did all the apt-get required).

when compiling (using the build.sh script) I get errors at RenderManager.cpp.

So I can't have an xbmc binary anymore (used to work)

I my missing something ?
Oh yes got the same problem. I updated svn nearly every day so I *should* know by now how to do it.
Here are the last lines of the make command:
Quote:xbmc/GUIWindowSettingsCategory.o: In function `CGUIWindowSettingsCategory::OnCli ck(CBaseSettingControl*)':
/home/xbmc/XBMC/xbmc/GUIWindowSettingsCategory.cpp:1234: undefined reference to `CVideoDatabase::CleanDatabase()'
collect2: ld returned 1 exit status
make[1]: *** [XboxMediaCenter] Error 1
make[1]: Leaving directory `/home/xbmc/XBMC'
make: *** [all] Error 2
2x pebkac
Thanks for that nice hint *g*
It seems that sometimes a "make clean" really makes sense Smile
Well I've already did that (make clean)

I have the problem from a fresh install of Ubuntu 7.04 with the first compilation attempt.

My command is :

./build.sh CONFIGOPT=--disable-gl

My understanding from the Readme is that : it updates to the latest version, does a cleanup and than compile without 3D support.

I will post the error later today.
I realize this forum is not for support. But discussion among users.
With that said.

I've previously loaded it on a test box and everything went fine.

So I loaded Ubuntu 7.04 on box previously running "MediaPortal". I plan on leaving it as a dual boot system until XBMCLinux is more mature. I loaded Ubuntu fine. Installed all updates. Checked out SVN and installed all dependencies listed in READE.LINUX.

But when I ran the ./build.sh script to compile it errored saying libGL must be installed and never created the XboxMediaCenter executable.

I have double checked and I have LibGL installed.

I installed it on my test box the day before and everything compiled fine.

Did something major change in the SVN yesterday?
I think there are still major changes in the SVN.

I've been trying to compile for the last week and it worked only yesterday (when trying to generate a log for posting : see my messages in this thread).

As I said, yesterday it compiled fine under Ubuntu 7.04

Don't forget to do a "make clean" if it is not your first compilation attempt.
Would there be a problem with someone uploading the compiled program or is that a no-no?
f4ion1 Wrote:Would there be a problem with someone uploading the compiled program or is that a no-no?

b/c this is running on Linux & not the XBOX?
XBMC for linux is not ready to be released and not for testing either.

The programer team knowing that we are anxious to play with XBMC :p so they let us compile and test without support.

So I think it is too early to post a compiled version.

I know for fact that 10424 compiles ok and you can force your svn to downgrade to this revision if after an update it wont.Wink
slash Wrote:XBMC for linux is not ready to be released and not for testing either.

The programer team knowing that we are anxious to play with XBMC :p so they let us compile and test without support.

So I think it is too early to post a compiled version.

I know for fact that 10424 compiles ok and you can force your svn to downgrade to this revision if after an update it wont.Wink

Awesome, I'll test with 10424 for now than. I'm a geek but never forced myself to use linux before. Now I have a reason.

Thanks for the info.
I use Ubuntu Gutsy Beta1.
I have compiled xbmc just fine, but after I did an apt-get upgrade Im getting this error:

PHP Code:
sound -lsqlite3 -lsmbclient -llzo -lfribidi -lfreetype -ldl -lcdio -lSDL_mixer -lSDL_image -lSDL -lXinerama -lGLU -lGLEW -lGL  -rdynamic
guilib
/TextureBundle.oIn function `CTextureBundle::OpenBundle()':
TextureBundle.cpp:(.text+0x1442): undefined reference to 
`__lzo_init_v2'
collect2: ld returned 1 exit status
make[1]: *** [XboxMediaCenter] Error 1
make[1]: Leaving directory `/home/xbmc/XBMC'
make: *** [allError 2
make
Leaving directory `/home/xbmc/XBMC'
make[1]: *** [XboxMediaCenter] Error 1
make: *** [all] Error 2 

So I guess some/one of the needed packages for compiling xbmclinux has been updated to a version thats not supported.
Hey f4ion1,

Starting revision 10425 (not 10424 my mistake Blush) the compilation seems to complete successfully.

Test and report results please.
Got the latest to compile last night and I've got it running.

Now if I can just get it to recognize my Microsoft IR receiver I'll be doing alright.

I'm having to use the keyboard for testing right now.

Are you using an IR receiver, if so what kind?
I have a home brew serial IR, but didn't take time to install under Ubuntu.

Works fine under Fedora and Windows XP.

Now that you got it running, could you share your tests results :

- Audio out, video performance (type of files)
- DVD playback
Pages: 1 2