Kodi Community Forum

Full Version: Subtitles cannot be turned off
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Before you tell me to RTFM, I have. I've tried every possible combination of options at Subtitles (wiki)

Operating system: Windows 8.1 (kernel: Windows NT 6.3)
Build: Kodi 16.1 Git:20160424-c327c53
Compiled: Apr 24 2016

When watching a movie, the subtitles are always displayed. I have tried pressing "T", the OSD says "Subtitles: Disabled," but they are still there. I use the mouse to hover over the subtitles button, and Enabled is not lit up. I go to the Audio settings window, and Enable subtitles is not checked. But the subtitles are still being displayed. They are not permanent subtitles in the video, because if I change the subtitle language, it changes these on-screen subtitles that I cannot get rid of.

This is extremely distracting when watching a movie. Is anyone else experiencing this problem, or knows what may be causing it? Thanks in advance.

Edit: In Settings > Videos > Subtitles, I have Preferred subtitle language set to "None". Playing the video in VLC, the subtitles are initially enabled but they go away when I choose Sub Track > Disable.

Edit 2: I just downloaded the Krypton 17 beta, and the problem is present there, too.
Where are you getting your movie from? Which source or add-on?
External hard drive, Movies. Just native Kodi.
More likely that the sub had been hard coded to the movie. If you did not rip the movie yourself then you know whodunnit.
No actually this is the second report of this happening, just can't find the other thread at present.

And it can't be hard coded if it is capable of being switched ot another language.
Try turning off parsing for closed captions. Settings->Video->Subtitles->Parse for closed captions
For reference the other thread is here. 287758 (thread)
(2016-09-03, 07:38)cd2022 Wrote: [ -> ]More likely that the sub had been hard coded to the movie. If you did not rip the movie yourself then you know whodunnit.
I mentioned in the original post that these are NOT hardcoded subtitles, because I can change the language through Kodi's interface and disable subtitles entirely in VLC with no problem.
(2016-09-03, 08:24)learningit Wrote: [ -> ]Try turning off parsing for closed captions. Settings->Video->Subtitles->Parse for closed captions
Thanks for the suggestion, but I saw this option already and it is disabled.
My apology for not seeing that info.