Kodi Community Forum

Full Version: Error: Exception caught on main loop. Exiting
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have this error code when i am choosing a movie and i accidentally press the backslash button, which makes the kodi into a window screen from full screen. When I try to his backslash again to make i full screen it doesn't work and it gives me that error code. Even if I press it accidentally and not do anything I see the kodi window say (not responding) then gives me the error code.

It does not do this on the home screen nor when selecting the genre, search, section part. Just when selecting movies are showing.


This only happens in my amber skin and not the default skin. I just recently came across this problem.

How do I add my kodi.log file to this thread?

Thanks in advance.
Read the forum rules (wiki) on piracy and banned add-ons (wiki).

We don't offer any support for installs contaminated with such crap, like yours.
This also happens on my emby server that I have added on to kodi as well. When selecting my movies that I have on my network
It's far from unknown for certain add-ons on that list to screw around with things that they have no business meeting with and making installs unstable or worse. Hence the rules - if you want support they need to go.

This thread is only so here in case @joethepartylion may wish to be aware of it.
I have edited my post, does that help?
No, as to understand the problem a debug log (wiki) would be needed, which will parade everything again.

It's not a case of just not mentioning the banned crap, it's not using it. There are too many examples of them getting in and messing things up on installs that we're frankly fed up with them and trying to unscrew what they do to installs sometimes. Hence the rule.

So if you want help and support a clean-up is needed and a clean log posted, or else this thread will go in the bin. I've tried to be patient with this, but that's coming to an end.
Oh I see, alright, I'll do a clean install of kodi and see if the problem still exist and i'll give the kodi log through the link that you have given.
Here is the link to my log file

I hope I did that right.