Kodi Community Forum

Full Version: Fast Forward with new Video Player
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have a problem with the new video player in Kodi Krypton on my Sony X850D (XD85) running Android TV 5.1.1. SoC is a MediaTek MT5890 with dual-core ARM Cortex A17.

I am playing a TransportStream with H.264 1080i and AC3 audio (via passthrough) via MediaCodec Surface.

When performing fast forward there is only a still image displayed. The image never ever gets updated, giving you no indication of where you are in the video. No matter whether you scrub at 2x or 32x. When resuming playback (1x), it takes about 10-15s until the video plays again.

In Kodi Jarvis there are frequent updates of the video image when performing fast forward.
Sorry, forgot about the log...

This certainly isn't specific to your chip or TV. This exact thing happens across all my Android devices, about 5 different chipsets and it goes back a while, too.
Seeking still broken with Beta 4 on Android. Is this supposed to stay this way?
Nope but we don't know the cause
I've got this same bug on Android 6.0.1, running latest Kodi Beta.

Hardware acceleration (Mediacodec) enabled: Can fast forward x2, but when I fast forward x4 the screen freezes. Video playback seems to be running in the background (timer moves), but no screen udpates: freeze frame.
Hardware acceleration (Mediacodec) disabled: No problems.
This appears to be fixed in a recent nightly build.
I am following the commits and haven't seen anything that goes in that direction. But things sometimes aren't that obvious Wink . Thanks for the heads-up. I will try it this evening.
Ah, probably this one and this one. I did mistake amc for aml and also DVD is a bit misleading in the file names.
On my Sony TV, Fast Forward is still not too good. 2x seems to work well, 4x doesn't update the image often anymore. 8x and higher still only gives me a frozen image. And it takes quite some time after going back to 1x that video is resumed. I used last night's build.

I used a TS recording with 1080i H.264 and AC3 audio.
I am streaming the stuff off of a NAS. The TV is connected via pretty fast AC WiFi. I just tried with latest official SPMC release too where seeking works quite well up to 32X.
Are others also having this issue? Is it a known one? Skipping seems to work reliably now. Fast forward/rewind doesn't.
Oh! Interesting... seems like Beta 6 does not support fast forward and fast rewind anymore, but only skipping/jumping. Is anybody able to elaborate?
On my Shield TV there is a different GUI. Instead to change the speed (2x - 32x), you use the direction keys to move forward or backward in the navigation bar. In case you click several times you make longer jumps. It is easy to get to the wanted position in the stream.
In my case it works much better better compared to the earlier GUI.
Yes, skipping indeed works better compared to fast forward (2x-32x) in Kodi Krypton beta builds. Fast forward (2x-32x) however worked very well in Jarvis, even on my weak Sony Android TV.
Pages: 1 2