Kodi Community Forum

Full Version: Intel Kaby Lake Hardware
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2017-04-22, 22:00)deaerator Wrote: [ -> ]This flickering is driving me mad.

What Driver version has the most stability?

I am using GFX 21.20.16.4627 drivers
I only get the flickering with res set at [email protected] Usually happens after a hard reset, putting the unit to sleep and waking it back up eliminates the flickering. I'm also using the latest drivers. Other are reporting the flickering issue over in the Intel Communities forum.

Sent from my HTC 10
(2017-04-27, 19:49)fmedrano1977 Wrote: [ -> ]I only get the flickering with res set at [email protected] Usually happens after a hard reset, putting the unit to sleep and waking it back up eliminates the flickering. I'm also using the latest drivers. Other are reporting the flickering issue over in the Intel Communities forum.

Try better HDMI cable.
(2017-04-29, 17:36)P.Kosunen Wrote: [ -> ]
(2017-04-27, 19:49)fmedrano1977 Wrote: [ -> ]I only get the flickering with res set at [email protected] Usually happens after a hard reset, putting the unit to sleep and waking it back up eliminates the flickering. I'm also using the latest drivers. Other are reporting the flickering issue over in the Intel Communities forum.

Try better HDMI cable.
Why would it be the HDMI cable if it's works absolutely fine other than from when the Unit is rebooted. After reboots the flicker is constantly there and the signal will drop, putting it to sleep and waking it back up, I'll never have the issue again till after a reboot. Others reporting the flickering issue in the Intel Communities as well.

Sent from my HTC 10
(2017-04-27, 19:49)fmedrano1977 Wrote: [ -> ]I only get the flickering with res set at [email protected] Usually happens after a hard reset, putting the unit to sleep and waking it back up eliminates the flickering. I'm also using the latest drivers. Other are reporting the flickering issue over in the Intel Communities forum.

Sent from my HTC 10 (typie typie)

Putting the unit to sleep seems to work for me also.
Thank you for the insight.
Asrock support sent me a new HDMI update.

https://mega.nz/#!Fo0AWRCC!VXJITMX6Cb70O...vwry2cquGk
(2017-04-29, 21:04)deaerator Wrote: [ -> ]Asrock support sent me a new HDMI update.

https://mega.nz/#!Fo0AWRCC!VXJITMX6Cb70O...vwry2cquGk
Yes, they sent me the same one.

Sent from my HTC 10
(2017-04-29, 21:04)deaerator Wrote: [ -> ]Asrock support sent me a new HDMI update.

https://mega.nz/#!Fo0AWRCC!VXJITMX6Cb70O...vwry2cquGk

looks like same v1.66 LPSCON firmware as Intel released a few weeks back
Please if using a Kaby Lake CPU with HDMI 2.0 join in on this forum on Intel's site to help get this issue with 3D playback on HDMI 2.0 and Kaby Lake addressed.

https://communities.intel.com/message/470997
(2017-05-01, 02:58)rmilyard Wrote: [ -> ]Please if using a Kaby Lake CPU with HDMI 2.0 join in on this forum on Intel's site to help get this issue with 3D playback on HDMI 2.0 and Kaby Lake addressed.

https://communities.intel.com/message/470997
Just wanted to say that I tested this on my Asrock Z270 Gaming/ITX, Core i5 7600K system. HDMI 2.0, DisplayPort, Thunderbolt 3 all output frame packing 3D from Kodi MSDK MVC builds. DisplayPort and Thunderbolt 3 outputs have wrong vertical frequency (11.98Hz instead of 23.976Hz). The output is correct with HDMI 2.0, but the problem is video identification code (VIC) is not set correctly in the output. This is the reason why you get a blank screen. HDMI analyzers can still show the video and that is how I know that it is frame packing 3D output. A video processor like Lumagen also works.

However, PowerDVD 17 output from 3D ISO is H-TAB.
(2017-04-29, 18:05)fmedrano1977 Wrote: [ -> ]Why would it be the HDMI cable if it's works absolutely fine other than from when the Unit is rebooted. After reboots the flicker is constantly there and the signal will drop, putting it to sleep and waking it back up, I'll never have the issue again till after a reboot. Others reporting the flickering issue in the Intel Communities as well.

Could be different issue, but new cable fixed occasional [email protected] flickering with my Beebox 7100.
(2017-05-01, 03:19)wesk05 Wrote: [ -> ]
(2017-05-01, 02:58)rmilyard Wrote: [ -> ]Please if using a Kaby Lake CPU with HDMI 2.0 join in on this forum on Intel's site to help get this issue with 3D playback on HDMI 2.0 and Kaby Lake addressed.

https://communities.intel.com/message/470997
Just wanted to say that I tested this on my Asrock Z270 Gaming/ITX, Core i5 7600K system. HDMI 2.0, DisplayPort, Thunderbolt 3 all output frame packing 3D from Kodi MSDK MVC builds. DisplayPort and Thunderbolt 3 outputs have wrong vertical frequency (11.98Hz instead of 23.976Hz). The output is correct with HDMI 2.0, but the problem is video identification code (VIC) is not set correctly in the output. This is the reason why you get a blank screen. HDMI analyzers can still show the video and that is how I know that it is frame packing 3D output. A video processor like Lumagen also works.

However, PowerDVD 17 output from 3D ISO is H-TAB.

Thanks @wesk05

This is first time info of what the issue is.
(2017-05-01, 03:19)wesk05 Wrote: [ -> ]However, PowerDVD 17 output from 3D ISO is H-TAB.

It is possible more in detail how to start 3D ISO in PowerDVD in H-TAB?
(2017-05-03, 08:49)NPoser Wrote: [ -> ]It is possible more in detail how to start 3D ISO in PowerDVD in H-TAB?
What I described is what I get on my analyzer. For all practical purposes, 3D playback doesn't work in PowerDVD 17.


(2017-05-02, 22:06)3DBuff Wrote: [ -> ]Thanks @wesk05
This is first time info of what the issue is.

There may actually be more to this problem. There may be a problem parsing HDMI 2.0 EDID also. EDID stored in Windows registry doesn't seem to have the 3D section. Can one of you with the Beebox-S 7100 save the active registry entry when using the HDMI 1.4 output and also with HDMI 2.0 output. You can use this program: http://entechtaiwan.com/util/moninfo.shtm or https://www.monitortests.com/forum/Threa...tility-CRU
https://downloadcenter.intel.com/downloa...dows-15-45-

Intel 21.20.16.4664 driver for Kaby Lake.