Kodi Community Forum

Full Version: DVD player framerate Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've tried for a while to play DVD's on my Raspberry Pi.
The hardware works and the Raspberry plays a kind of video with green and gray squares when the video begins, the framerate drops to 1 FPS :/

I don't know if it's the mpeg2 codec or the usb speed but it works for a movie put on a usb stick

Thanks for reading

Do you have an MPEG-2 license key purchased and installed on your Pi?

If not then you're decoding by software only rather than hardware, which may struggle. Presumably if you've put the movie on a stick you've ripped it to another format and so worked around it that way?
I don't want to purchase a MPEG-2 license key ; (

I tried with a .AVI and it Works but I'm going to try with MKV and MP4 ^^^
Why, it's only £2.40 and without it you won't be able to do what you are trying to do (as you've discovered).

Your alternative is to rip the DVDs and use other formats, again as you've already found out yourself.
Its ok , I bought aket , put in config.txt and it's done lel
Thread marked solved.