Kodi Community Forum

Full Version: ProjectM crashes kodi while playing music
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello everybody !

I get an issue while using Kodi and playing music with Projectm visu. It works fine for a little while (near 8 to 10 seconds), and it crashes, restarting kodi

- Using Xubuntu LTS 16.04 (had to move projectm directory as advised here. )
I had to execute that code :
Code:
sudo mv /usr/lib/x86_64-linux-gnu/addons/* /usr/lib/kodi/addons/
- And Kodi 16.1 Jarvis

Does anybody get the same issue, and successfully fixed it ?

here is my crash log (Or I think it is ...)

Code:
############## Kodi CRASH LOG ###############

################ SYSTEM INFO ################
Date: jeudi 24 novembre 2016, 14:40:23 (UTC+0100)
Kodi Options:
Arch: x86_64
Kernel: Linux 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016
Release: Ubuntu 16.04.1 LTS (Xenial Xerus)
############## END SYSTEM INFO ##############

############### STACK TRACE #################
############# END STACK TRACE ###############

################# LOG FILE ##################

14:38:38 T:140173530970432  NOTICE: special://profile/ is mapped to: special://masterprofile/
14:38:38 T:140173530970432  NOTICE: -----------------------------------------------------------------------
14:38:38 T:140173530970432  NOTICE: Starting Kodi (16.1 Git:c327c53). Platform: Linux x86 64-bit
14:38:38 T:140173530970432  NOTICE: Using Release Kodi x64 build
14:38:38 T:140173530970432  NOTICE: Kodi compiled Apr 25 2016 by GCC 5.3.1 for Linux x86 64-bit version 4.4.6 (263174)
14:38:38 T:140173530970432  NOTICE: Running on Ubuntu 16.04.1 LTS, kernel: Linux x86 64-bit version 4.4.0-47-generic
14:38:38 T:140173530970432  NOTICE: FFmpeg statically linked, version: 2.8.6-kodi-2.8.6-Jarvis-16.0
14:38:38 T:140173530970432  NOTICE: Host CPU: Intel(R) Celeron(R) CPU 847 @ 1.10GHz, 2 cores available
14:38:38 T:140173530970432  NOTICE: special://xbmc/ is mapped to: /usr/share/kodi
14:38:38 T:140173530970432  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/kodi
14:38:38 T:140173530970432  NOTICE: special://masterprofile/ is mapped to: /home/kodi/.kodi/userdata
14:38:38 T:140173530970432  NOTICE: special://home/ is mapped to: /home/kodi/.kodi
14:38:38 T:140173530970432  NOTICE: special://temp/ is mapped to: /home/kodi/.kodi/temp
14:38:38 T:140173530970432  NOTICE: The executable running is: /usr/lib/kodi/kodi.bin
14:38:38 T:140173530970432  NOTICE: Local hostname: KODI-PC
14:38:38 T:140173530970432  NOTICE: Log File is located: /home/kodi/.kodi/temp/kodi.log
14:38:38 T:140173530970432  NOTICE: -----------------------------------------------------------------------
14:38:38 T:140173530970432   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - La propriété « CanSuspend » n'existe pas
14:38:38 T:140173530970432   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - La propriété « CanHibernate » n'existe pas

Thanks for replies ! Cya !

Hardware specs :
-Celeron 847
-2Gb RAM
-ASUSc8hm70-i/hdmi
-2Tb Western Caviar RED
Install gdb (sudo apt-get install gdb) then crash Kodi again and you should get a backtrace in the crashlog. Post it to pastebin or the like and post the URL here.
Hi black_eagle, and thanks for replying.

As you said, I did it again (lol oops) ahem...

here is the pastebin :

http://pastebin.com/eLCHygpc

I forgot to precise that I'm right now using the Nebula theme for Kodi, and I've just tried with Confluence, it seems to be working...
Ok it does not appear in the logs, but it still crashes with Confluence, my mistake... but it crashes always when I'm navigating in menus.
(2016-11-25, 15:03)Syc0 Wrote: [ -> ]Ok it does not appear in the logs, but it still crashes with Confluence, my mistake... but it crashes always when I'm navigating in menus.

Can you post a link to your crashlog (crashlog will be in your home directory & starts kodi_crashlog) after you installed gdb. Kodi will automatically use gdb to produce a backtrace of itself when it crashes which is in the crashlog.

Also, you didn't enable debug logging in your previous log. See debug log (wiki) if you're unsure how to do this.
without backtraces nobody will be able to help you with anything. i did improve a nasty threading situation (not completely resolved apparently) in projectm add-on about a week ago.
Hi ironic_monkey, I've made a new crash log pastebin, click HERE.

It seems to be more stable in "medium quality" (in projectm parameters) sounds like a drivers problem isn't it?

Here is the crash log when "medium" graphic configuration is selected in ProjectM parameters : CLICK HERE

Many thanks for help !
Hmmm, you don't appear to have gdb installed (see my post above). Ironic_monkey will probably be able to help (as the vis stuff are his babies) but not without a proper backtrace.

If you have installed gdb properly then the crashlog should look similar to this (but much longer !!)

Code:
############## Kodi CRASH LOG ###############

################ SYSTEM INFO ################
Date: Sun Oct  9 12:53:12 BST 2016
Kodi Options:
Arch: x86_64
Kernel: Linux 4.5.0 #2 SMP Mon Aug 8 16:08:25 BST 2016
Release: Ubuntu 14.04.5 LTS, Trusty Tahr
############## END SYSTEM INFO ##############

############### STACK TRACE #################
=====>  Core file: /home/xbmc/core (2016-10-09 12:52:53.721021568 +0100)
        =========================================
[New LWP 15137]
[New LWP 14978]
[New LWP 15149]
[New LWP 14981]
[New LWP 14989]
[New LWP 15131]
[New LWP 14990]
[New LWP 15153]
[New LWP 15110]
[New LWP 15132]
[New LWP 15112]
[New LWP 15113]
[New LWP 15133]
[New LWP 14991]
[New LWP 15114]
[New LWP 15136]
[New LWP 15148]
[New LWP 15150]
[New LWP 15151]
[New LWP 20460]
[New LWP 15152]
[New LWP 15116]
[New LWP 14975]
[New LWP 15154]
[New LWP 15155]
[New LWP 15203]
[New LWP 15212]
[New LWP 15338]
[New LWP 16312]
[New LWP 2839]
[New LWP 17998]
[New LWP 18002]
[New LWP 5442]
[New LWP 15156]
[New LWP 15337]
[New LWP 15118]
[New LWP 15119]
[New LWP 15135]
[New LWP 15117]
[New LWP 3286]
[New LWP 15120]
[New LWP 14982]
[New LWP 16313]
[New LWP 15336]
[New LWP 16355]
[New LWP 15124]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/lib/kodi/kodi.bin'.
Program terminated with signal SIGABRT, Aborted.
#0  0x00007f3058902c37 in __GI_raise ([email protected]=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
sudo apt install gdb
sudo systemctl stop apport

then let it crash again. Do not reboot after stopping apport
Thx Wsnipex,

I stopped apport service and then GDB Looks to be working.

Find here crash log result.

it's an OMG huge one ^^