Kodi Community Forum

Full Version: Rii Mini i8 Bluetooth Issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there,

I just got a couple of these remotes. I've used them a lot before, but never the Bluetooth versions.

I'm having a hard time getting the Keyboards to hook up to my Android boxes (H96 Pro+). The Keyboards will go into pairing mode, and it will even say they are connected, but nothing works. It's like the keypad is locked.

Also... I've hooked both of the Riis up to other Bluetooth compatible devices and I've hooked other Bluetooth devices up to the android box to see if they worked there. In all cases everything worked fine... except for the Riis on the Android box.

Am I missing something else here? Do I need to set it to a different keyboard language in order to function.

Confused and Frustrated. Any help would be appreciated.

Thanks,

Hanner
Do they work in other android apps? If not, this isn't a kodi issue.
I have exactly the same problem, my Rii mini i8+ connects to my H96 pro box but does not work. I have tested the keyboard on my win10 computer and Samsung tab S2 and it works fine. Just not the H96 pro. I know it is running the latest android 6, could this be a problem?
@Colwin, not exactly a Kodi question.

Anyway, I'll repeat what I said above "Do they work in other android apps? If not, this isn't a kodi issue."

If it is an issue of not working in the latest android, I am sure that will be discussed on the web already. Google is your friend.

If the device works in the rest of android, but not kodi, then post a debug log (wiki)
First off I don't think this is a Kodi problem, it appears to be a H96 Pro Plus Android TV Box problem.

I have the same Rii Remote and am having the same issues so I am posting here in case anyone on this forum has had this issue and figured out the problem. I have done several searches and this is the closest I came to finding it discussed on a forum (even though there was no resolution).

Taken from email I sent to the seller:
I have tried to connect multiple Bluetooth devices and they will not work with the H96 Pro Plus.
I have tried the Bluetooth devices with BOTH H96 Pro Plus that I ordered and am getting the same results on both units.
It appears the Bluetooth signal will not stay on or it flickers on and off.
The Bluetooth mouse I am attempting to use does not have a smooth motion, it is moves in a choppy, pulsing motion.
The Bluetooth keyboard/mouse unit will not even connect or will not stay connected long enough to work at all.

I have used these Bluetooth devices with other computers/tablets and they work properly so I know that the mouse & mouse/keyboard are not the problem.

I am hoping there is a simple solution that you can help me with.
Is there a setting or something I am not aware of that will enable to Bluetooth devices to work properly with both the H96 Pro Plus units I have purchased?

I would much rather resolve this issue with your help rather than have to return both of these products for a refund.

*The mouse works smoothly for a couple seconds when connecting or when disconnecting but then gets this choppy/stutter motion. So it is kind of working, it is receiving the signal but its almost like there is some type of interference.
Here is a link to a forum where I bought the device:
http://forum.banggood.com/forum-topic-313084.html

Basically they know of the issue but are offering no help.

If anyone has figured out how to get Bluetooth working on this device please add a post...Thanks.
(2016-12-26, 00:40)Hanner18 Wrote: [ -> ]Hi there,

I just got a couple of these remotes. I've used them a lot before, but never the Bluetooth versions.

I'm having a hard time getting the Keyboards to hook up to my Android boxes (H96 Pro+). The Keyboards will go into pairing mode, and it will even say they are connected, but nothing works. It's like the keypad is locked.

Also... I've hooked both of the Riis up to other Bluetooth compatible devices and I've hooked other Bluetooth devices up to the android box to see if they worked there. In all cases everything worked fine... except for the Riis on the Android box.

Am I missing something else here? Do I need to set it to a different keyboard language in order to function.

Confused and Frustrated. Any help would be appreciated.

Thanks,

Hanner
   I've found that if you let the pairing cycle run to timeout the connection goes away.

Purchased and new Bluetooth MS laptop mouse which I couldn't get paired. However, if you kill the pairing after CONNECTING shows but B4 PAIRING FAILED guess what the device is registered and CONNECTION is complete.

I tried this with the RII I8. Sure enough the blue light stays on. Sitting in the Setup Menu around the Bluetooth devices I can turn RII power on/off and get CONNECTED on/off showing on the screen. Keys don't work. Sad

When I paired the RII to my Amazon Fire Box and WECHIP box I had to enter a 5 digit number displayed on the screen from the boxes. There in lies the problem, the Bluetooth driver/app on the H96 isn't doing this.
Maybe the process of entering a code is a security thing and some flag isn't getting set.

Interesting enough went done the apps to a Bluetooth app click on and opened it. Got to a point where I found Bluetooth Disconnected even though it was running. Nope that didn't fix it. Will continue looking.

It's a real shame because of the 4 units I've had the MBOX has been the solidest and fastest. Rarely have to pull the power cord because I pull USB devices off(not flash drives) or added a new app or one crashed.

Oh, by the way the BoxWave keyboard works well over 20 feet. So with this and my MS mouse I'm somewhat happy. Would prefer the cute red RII.

I'm new to the the TV Box world. Do these manufacturers make fireware updates available? Or is the H97++++++PRO next.

Have been able to use old keyboards/mouses wireless with a dongle and transceiver on a wire connected to a USB port but range stinks. Even the RII wireless dongle doesn't work in the H96.

Bob