Kodi Community Forum

Full Version: Kodi Crashing when updating Version - Possible problem with MySQL
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I have done alot of reading and nothing seems to address my issue, though some of the threads have helped in diagnose.

I have been waiting for an updated version of OpenElec to be released and now that it has, I am trying to update all my kodi machines.

I am experiencing an annoying problem with kodi crashing on startup.

I am using MySQL on a QNAP NAS as a shared library and it works great with v15.2. However when I put my settings file into v16.1 it crashes on startup, regardless of the type of device. Here is the error message I get from windows. Is there a clean way for me to post the kodi log file.

Problem signature:
Problem Event Name: APPCRASH
Application Name: Kodi.exe
Application Version: 16.1.0.0
Application Timestamp: 571c922e
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.1.7601.23572
Fault Module Timestamp: 57fd0379
Exception Code: e06d7363
Exception Offset: 0000c54f
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 3081
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789




I would ideally like to to update the database but if that is not possible I will just create a new one.

Thankyou for any help that can be given.
debug log (wiki)

What kodi database versions exist on the mysql server?
There is v93. I understand that the database version for kodi 16.1 is v99
OK the reason I asked is that sometimes people update a machine to a new version, and don't wait for it to update the dB on first startup. This results sometimes in a corrupt or incomplete database.

But if there is no sign of a MyVideos99 database then that doesn't seem to have happened.

Can you provide a debug log please (link to the wiki in my last post, but the wiki is down right now).
Yes that was one of the things i checked, thanks to the other posts.

I will post the log file when the wiki is back up.

I might also add that without the advanced settings file, kodi starts fine.
So are all machines crashing, or just the windows one?
All of the machines crash when using the settings file but are fine without it. When not using the settings file i can't use the shared database
Debug log (wiki)
You've locked yourself out of your MySQL database.

http://stackoverflow.com/questions/19034...7#19034657
I found the max connections in the mysql setting and it is now set to max

Kodi still crashes however: http://paste.ubuntu.com/23737168/
Drop the kodi_test99 database.
I just removed the "_test" from the database name in the advancedsettings file and it now boots fine.


I will have to recreate/scan in my media but hey its better than nothing.

Thank you very much for the support and advice