Kodi Community Forum

Full Version: UPnP Remote Media Source no longer works in v17.0
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
In all previous versions this worked for me.

My Verizon FIOS DVR (Media Server) allows watching basic non-encrypted live TV channels through any network connected DNLA/UPnP device. In v17.0 RC1 & 2 the server is found and all channel numbers displayed but when PLAY is pressed, there is a spinning circle and then back to the channel chart. I deleted the video source and entered it again with no luck.

The above is on (2) Windows 10 Desktop computers.

My 2 Intel NUC's running OpenELEC 7.0 (Kodi 16.1) work properly with this UPnP source.


Edit: I installed 17.0 RC3 tonight and the problem still exists. It seems like it's trying to play a file rather than a video source.
Edit 2: I installed 17.0 RC4 today (Jan 27, 2017) and the problem still exists.
I updated both of my Intel NUC's from OE 7.0.1 to LE 8.0.1 (Kodi 17.1). When I select a video source (UPnP devices), the server is found, named and added successfully. All channel numbers and names are added too. When I select a channel, there is a round spinning wheel for a second or two and then it displays the channel guide again. Between Kodi 16 & 17, something was deleted or changed with respect to UPnP/DLNA playback. I posted the logs in the previous post showing the errors.

Anyone ?
I upgraded one of my Windows 10 desktops to version 17.5 today and my problem still exists. Kodi version 16 allowed me to watch select Verizon FIOS TV Channels through my wired network from the DVR (Media Server) using the UPnP/DLNA feature built into Kodi. For the last 10 months I haven't been able to use this Kodi feature. Did Kodi disable it ?

I supplied a log previously but got no replies
(2016-12-31, 20:18)blueribb Wrote: [ -> ]http://pastebin.com/GYSzVhSh

This isn't a compete Debug log (wiki).
(2017-10-24, 19:10)Rechi Wrote: [ -> ]
(2016-12-31, 20:18)blueribb Wrote: [ -> ]http://pastebin.com/GYSzVhSh

This isn't a compete Debug log (wiki).

It covers the entire time I started & stoppedĀ the UPnP Media Source
(2017-10-30, 15:15)blueribb Wrote: [ -> ]It covers the entire time I started & stoppedĀ the UPnP Media Source

Either you provide a complete Debug log (wiki) or you won't get any help.
I think it would be useful to also see a log from a machine that IS working.

Looking through from line 749, you can see Kodi processing the upnp url, but ending up with no data (790).

Also before that I see that the url requested has mimetype application/x-dtcp1 - dtcp is digital transmission copy protection (according to google) - dunno if this is something about how inputstream handles what is returned by the URL or not.
All of my computers are running Kodi 17.5, so I would have to install an older version (16.0) and generate a log. I'll try and do that later today.

Verizon uses the dtcp protocol to protect most of their channels (not all). There are a dozen or more channels that are not encrypted. Those channels always worked with Kodi 16.0 and older versions. It's been almost a year since I have been able to use Kodi to watch those channels.

Note: Kodi seems to be handling the Verizon Media Server as a FILE instead of a STREAM. It sometimes asks if I want to start from "XXX minutes" or "the beginning". It never did this in version 16.0 and older of Kodi.

Will I be able to install and use the Kodi Logfile Uploader in version 16.0 ?
Here's a log file from an old Windows 10 desktop computer running Kodi 16.0
My Verizon Live TV works again !

Installed Kodi 17.6 today and crossed my fingers. Nope, upnp/dlna Verizon Live TV stream still does not work. But it is working perfectly on Kodi version 16.0

Windows 10 Desktop
Kodi 17.6
Verizon (Arris VMS1100 DVR / Media Server)

Edit: I tried a nightly version (Kodi 18.0-ALPHA1 Git: 2017 1117 - a1ce739) and the upnp stream still did not work at all.
Here are 2 short videos showing the Verizon upnp stream failing (Kodi 17 & up) and then working (Kodi 16)

Kodi Version 17 / 18 upnp streaming fails: https://drive.google.com/open?id=1FKxJ8S...cd0YRCphCn

Kodi Version 16 upnp streaming works: https://drive.google.com/open?id=1Mgr0wV...W960n21GT3
I looked at your logs and it seems clear what is happening, but I have no idea how to fix it (not a programmer).
Are there any programmers here that could look at my logs and suggest a fix ? I would really like to watch live TV again using Kodi. I really miss it. It's been a year since I first posted this.
Sorry about bumping this thread but I still cannot use Kodi to watch Verizon FIOS live TV like I did in previous versions. I supplied complete logs and even videos showing the problem. Can anyone help ?
Pages: 1 2