Kodi Community Forum

Full Version: RC6 and MCE remote
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I am running Kodi 17-Beta 7 on Fedora 25 base. My remote is a HA-IR01SV (TSHA-IR01).

When I run 'ir-keytable -t', all the buttons show up when I press them, as mapped in '/etc/rc_keymaps/rc6_mce (I do not have Lirc installed; it is using all in-kernal RC6) In Kodi, however, quite a few of the buttons have no effect whatsoever, in particular the Red and Green buttons, and Guide. My understanding is "Guide" is typically mapped to ContextMenu (though in the meantime, I have mapped the Blue button to that)

Up until last week or so, I was running Kodibuntu,and out of the box, all the buttons just worked. I don't know if KodiBuntu uses Lirc in conjunction with (or instead of) RC6?

I have tried following a few guides and using some recommended keyboard.xml files, but no matter what, there are just those few buttons that Kodi just cannot seem to recognise.

Any thoughts? Thanks! :-)
OK, I figured it out. I changed my '/etc/rc_keymaps/rc6_mce' file so 'KEY_EPG' (which is the "Guide" button) to 'KEY_C' (which sends the keyboard "c" command)

Apparently X11 cannot understand decimal codes above 255, which is why the key codes were showing up in 'ir-keytable -t' (command line, no X11) and not in Kodi (running in X11). So the issue is not Kodi, but rather X11.

If I wanted to map the other MCE-specific buttons (Videos, Pictures, etc.) which don't currently generate any key codes to X11, I just have to change the corresponding keys codes in '/etc/rc_keymaps/rc6_mce' to the appropriate keyboard shortcut.