Kodi Community Forum

Full Version: Kodi crashes when it starts to scan NAS stored movies
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there,

I have an old Apple TV 2 with Kodi 14.2... it has been working for me for years, but since Kodi no longer supports these boxes, I decided to upgrade. I bought an off-the-shelf Android TV box (Goobang Doo ABOX III).

First some context.

I have a DNS-323 NAS where I have some movies stored. This NAS is accessible through SMB. The Apple TV Kodi has been using it for years, and never had an issue. I have three main folders for these movies; Kids Movies, Movies and Kids TV.

The new Kodi box came with a version of Kodi but as I have been having issues with it, I removed it and installed a stock 16.1 version from the Google Play Store. The box has Android TV 6.0 and Kodi 16.1.

I added the Kodi Logfile Uploader add-on, and added the folders for my videos. I basically added the folder for the Kids Movies then set it to Movies content then executed the scan for new content option. Kodi crashed within 2-3 seconds. Here is the log in debug:

https://paste.ubuntu.com/23791941/

and here is what I have tried:

If I add the Kids TV folder and set it to TV Shows, it scans fine.
If I set the Kids Movies folder to TV show content, it scans fine as well.
If I change the Movie Database scanner to be the Universal Scanner, Kodi crashes as well.

thanks for your help.
Try uninstalling the movie scrapers and reinstalling them.
(2017-01-14, 13:22)sy278 Wrote: [ -> ]Try uninstalling the movie scrapers and reinstalling them.

Hi there,

Thanks for the suggestion. For some reason, the "The Movie Database" add-on has the remove button disabled. I did some research and ended up deleting the plugin directly from the addons folder, then updated it through the UI. I then tried to start the scan and Kodi crashed again. I also tried the Universal Movie Scraper and another random one... they all crashed Kodi when the scan started.

This would make me think it is a problem with Kodi accessing the NAS storage, however, I can see all the movies in that folder from Kodi... also, if I set the content to TV Shows, the scan works fine.. it just does not work because they are not shows.
@areis1974 Did you find a fix?

I crash at every startup. Can't watch anything. Confused
(2017-06-04, 04:01)whataboutchris Wrote: [ -> ]@areis1974 Did you find a fix?

I crash at every startup. Can't watch anything. Confused

Hi there, I never found a fix. I returned the box to the seller. They could not figure it out either
(2017-06-04, 04:01)whataboutchris Wrote: [ -> ]@areis1974 Did you find a fix?

I crash at every startup. Can't watch anything. Confused

If you would like help in resolving your issue, can you post a debug log. Instructions are in my signature below.

Once you enable debugging mode, restart kodi until it crashes, then upload the log to a pastebin site.