Kodi Community Forum

Full Version: RC3 Installation Problem on FireTv 1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've been running 16.1 without any problems so far. Today I tried to install 17RC3 using adblink after uninstalling 16.1. I was getting the "Old SDK" error message. I also tried to install it from ES Explorer withing FireTv but then the "problem with parsing the package" showed up. After failing all the attempts, I switched back to 16.1 the installation of which had no issues whatsoever. I would really appreciate any feedback on this. Thanks![/b]
Are you running the latest official aftv1 firmware?
(2017-01-18, 09:07)indijones Wrote: [ -> ]I've been running 16.1 without any problems so far. Today I tried to install 17RC3 using adblink after uninstalling 16.1. I was getting the "Old SDK" error message. I also tried to install it from ES Explorer withing FireTv but then the "problem with parsing the package" showed up. After failing all the attempts, I switched back to 16.1 the installation of which had no issues whatsoever. I would really appreciate any feedback on this. Thanks![/b]


You don't need to uninstall 16.1, just install 17. Are you using the correct apk file? It should be the ARMv7a (32 bit)
My FireTv was rooted and the update was blocked. I was using 32 bit ARMv7a file from kodi website. Then I did a factory reset that removed the root and updated the firmwire from 51.1.0.0 to 51.1.6.3. Even after that I am getting the same error!
If I'm not mistaken, 51.1.6.3 is still FireOS3, ie Android 4.4, so not compatible with Krypton.
Update to FireOS5 or forget about Kodi 17...
Thanks! Got it installed after updating to OS 5.