Kodi Community Forum

Full Version: After upgrade to Kodi17 AC3 stereo doesnt play
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have Kodi installed on my Nvidia Shield and now it wont play AC3 stereo (2 channel) videos.

I had 16.1 installed but overnight Kodi 17 was installed (I didnt realize I had automatically install updates checked) and now stereo Dolby doent play on videos. I get a brief message but havent been quick enough to get a pic or even read it. Ive got a high end sound processor and amp but they do me no good for Dolby stereo now. Whats that all about?
Without a http://kodi.wiki/view/Debug_log it's a mystery.
15:46:08.580 T:1628420384 NOTICE: Creating InputStream
15:46:08.830 T:1628420384 NOTICE: Creating Demuxer
15:46:10.103 T:1628420384 NOTICE: Opening stream: 0 source: 256
15:46:10.103 T:1628420384 NOTICE: Creating video codec with codec id: 13
15:46:10.103 T:1628420384 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: MPEG-4 part 2
15:46:10.104 T:1628420384 NOTICE: Creating video thread
15:46:10.104 T:1628420384 NOTICE: Opening stream: 1 source: 256
15:46:10.104 T:1769560352 NOTICE: running thread: video_thread
15:46:10.104 T:1628420384 NOTICE: Finding audio codec for: 86019
15:46:10.105 T:1628420384 NOTICE: Creating audio thread
15:46:10.105 T:1782286624 NOTICE: running thread: CVideoPlayerAudio:Tonguerocess()
15:46:10.124 T:1782286624 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
15:46:10.125 T:1782286624 NOTICE: Creating audio stream (codec id: 86019, channels: 2, sample rate: 48000, no pass-through)
15:46:10.125 T:1582020896 NOTICE: Trying to open: 48000 samplerate 12 channelMask 4 encoding
15:46:10.130 T:1582020896 NOTICE: CAESinkAUDIOTRACK::Initializing with: m_sampleRate: 48000 format: AE_FMT_FLOAT (AE) method: PCM stream-type: PCM-STREAM min_buffer_size: 32832 m_frames: 2052 m_frameSize: 8 channels: 2
15:46:10.142 T:1570756896 NOTICE: Using GL_TEXTURE_2D

I had to turn off Passthrough and enable stereo upmix to get sound. Didnt have to do that before 17
No snippets. You'll need to provide a link to your FULL debug log. Don't post the log text in the thread please.