Kodi Community Forum

Full Version: Kodi not displaying TMDB results when manually selecting
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Kodi has scrapped the incorrect title for whatever reason.

When I try to correct this by selecting Information->Refresh->Ignore and refresh from Internet->Select Movie

I can't see the title that I want, yet I can see it on TMDB

e.g. file called "WRC 1996 Review.mp4"

TMDB "https://www.themoviedb.org/movie/439423-world-rally-review-1996?language=en-US"

Kodi is not showing that as an option, but all the other titles for the other years.

By the look of that entry your file should be named. WRC 1996 - FIA World Rally Championship.mp4
Yep, tried that and no difference. Is there a limit on the number of titles kodi will retrieve from TMDB ? I can only see 12

TMBD has 21 entries
There is 1 exact match which Kodi does not want to match. When I remove the title and rescan, still it does not work. When I try to set it manually, I don't see that title as an option. It seems to show only 12 results I am guessing it is using the keyword "WRC". Why is Kodi only displaying 12 results and only the years of "2000" onwards? I can see 2001, 2002, 2003, etc etc. but not a single results from 1990s?
That I don't know sorry. Perhaps a debug log (wiki)?
I was having the exact same issue with another entry.  My file name matched the title exactly, and no combination of manual search criteria would retrieve the entry in Kodi's search results.  To work around this issue, I added the year in parentheses after the title.  For this entry, a file name of "In Short (2007).mp4" found a match:


I think I've seen this info posted elsewhere, but I figured I'd post it here for others who try a similar google search to find this thread like I did.
Another option would be using a Parsing NFO file. This will take Kodi directly to the show you require... http://kodi.wiki/view/Nfo#Parsing_nfo
The year should always go in movie titles and directories, Like

source/Avatar (2009)/Avatar (2009).mkv

Although to be correct it will only matter in the directory name, I just keep them the same for consistency.