Kodi Community Forum

Full Version: Midi support with Krypton.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Ironic_monkey : sorry for my mistake- your addon is not compiled, it's different from the few addons I use (Cu Lrc lyrics, ...you install them through Kodi gui.)
When I get a problem I cannot solve, I ("contourne le problème") turn around it ?
I can install a virtualbox linux machine just to compile your addon : at the end, I'll get a folder with all necessary files...
What Linux distro should I use to be sure to find your headers ?

Wsnipex : my english is not good enough to understand what you mean "* wsnipex gets some popcorn"
A * stands for any character, pop corn is made of corn, and wsnipex is you Huh
@snblg the tone of your reply to @ironic_monkey sounded argumentative, unappreciative and insulting, so @Wsnipex's comment related to that. He was being sardonic, implying that a drama was about to unfold, so he was getting some popcorn, like he would to watch a movie.

Do not expect @ironic_monkey to jump through hoops for you, he is a volunteer doing this all for fun, so why would we want to spend any more time replying to you?
(2017-02-25, 09:50)DaveBlake Wrote: [ -> ]@snblg the tone of your reply to @ironic_monkey sounded argumentative, unappreciative and insulting, so @Wsnipex's comment related to that. He was being sardonic, implying that a drama was about to unfold, so he was getting some popcorn, like he would to watch a movie.

Do not expect @ironic_monkey to jump through hoops for you, he is a volunteer doing this all for fun, so why would we want to spend any more time replying to you?
@ Ironic_Monkey:
I feel sorry. I never thought I was"unappreciative and insulting". I did appreciate your help.
I wrote : "thanks" 4 times in this subject. I know giving answers is time consuming.
New user, I do not know yet who develops what with Kodi ; I've discovered quite late you are the author of this useful addon.
Author or not does not mean I can be insulting or not.
For sure, I have to study english and be very careful writing in english so that my words mean what I think.
Mes excuses si j'ai blessé ou paru insultant, ce n'est pas du tout l'état d'esprit dans lequel j'étais. Je suis sincère.

@DaveBlake
Thank you for your explanations about popcorn and my way of writing in english. I'll try to be more careful next time.
I may have been too harsh on you too - normally I'm a friendly guy, and music support a happy place Smile
I also know that @ironic_monkey can take care of himself, he has been contributing to Kodi for many years.

So sorry for butting in, I have nothing useful to add regarding Midi support.
I did some more tests :

I installed an Ubuntu virtualbox on my archlinux with ubuntu-16.10-desktop-amd64.iso
I installed kodi (krypton) and audiodecoder.timidity (straightforward with synaptics compared to archlinux)
I installed the corresponding soundfont with synaptics.
No other program installed on this fresh Os.
I activated the midi addon inside Kodi, with the french GUI setting
I installed the logviewer addon
No other Kodi changes - no other addon.
I copied some midi files in a folder, added them to my fresh Kodi"virtualbox" library.

Playing midi files generates errors and no sound.
( I can listen those midi files without Kodi on this virtual machine)

Error log shows :
1:20:46.214 T:140624042919680 ERROR: EXCEPTION: Non-Existent Control 1
21:20:50.975 T:140623796987648 WARNING: Attempt to use invalid handle -1
21:21:23.660 T:140625263767040 WARNING: Previous line repeats 2 times.
21:21:23.660 T:140625263767040 WARNING: CreateLoader - unsupported protocol(sources) in sources://music.tbn
21:21:45.951 T:140625263767040 NOTICE: ADDON: Loaded virtual child addon special://temp/audiodecoder.timidity-0.0
21:21:45.957 T:140625263767040 WARNING: CAEUtil::GuessChLayout - This method should really never be used, please fix the code that called this
21:21:45.957 T:140625263767040 ERROR: CAudioDecoder: Unable to Init Codec while loading file /home/me/Echange/F/Ferrer_Nino/lamaison.mid
21:21:45.957 T:140625263767040 WARNING: PAPlayer::QueueNextFileEx - Failed to create the decoder
21:21:45.957 T:140625263767040 ERROR: Playlist Player: skipping unplayable item: 6, path [/home/me/Echange/F/Ferrer_Nino/lamaison.mid]


Because of this error, I did not try to copy the addon files from my virtual ubuntu to my real archlinux system.

I will wait : if people form archlinux update the repository, so that it can be installed as easily as under Ubuntu, I'll try it.
(I use the yaourt bash command under arch - the Ubuntu equivalent is synaptics / yaourt is a bit like pacman )
Just to remember what I tried to explain before, compiling from the official aur repository fails, and the necessary Kodi headers are not available for my archlinux os = I cannot compile from the github official website. People from archlinux forum cannot help me with those packages.

Thank you to all participants for your help and comments. That was "très formateur pour moi - toute expérience est enrichissante"

Here is a part of screenshot of my archlinux showing my virtual Ubuntu :

Image
My problem is solved and I do not use Kodi anymore.
Kodi is great, but Vlc does exactly what I need.
I do not need any media center as I only work with desktop computers.
Music is my main concern : I do not watch Tv.

Configuring Vlc so that it plays midi files is really easy under Linux : 10 lines to follow here.
Vlc manages libraries (Médiathèque into french) : I've added all my media inside Vlc Gui from my folders by simple drag and drop actions: fast, ! - No drag and drop with Kodi.
Adding my files (total 170 Gb ) is faster under Vlc vs Kodi.
Probably because Kodi fills a database, Vlc, no.
Not sure a database is necessary for my needs : it's so fast to search and find under Vlc !

Vlc plays midi with good quality under Linux : it also uses soundfonts from my Native Maschine Studio Software/hardware that runs under Windows. Moving from one soundfont to another one is really easy.

Using mouse and keyboard with Vlc is easier than with Kodi :
try to copy and paste some text to Kodi search window ...
mouse disappears under Kodi, you have to move it...

Of course, Vlc plays files from samba shares, as Kodi does, but Vlc does not fill my local harddisk with thumbnails.
My .kodi folder was over 1.5 Gb after 3 weeks use.
My .vlc folder : 92k !

I also use another software : QSynth; it's not related to Vlc, but it's also useful.

Bye and have fun with Kodi.

Image


Below, files from Samba share from my desktop server.

Image
@ironic_monkey
hello,ironic_monkey,
I catch this error while cmaking the timidity:

CMake Error at CMakeLists.txt:9 (find_package):
By not providing "FindKodi.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "Kodi", but
CMake did not find one.

Could not find a package configuration file provided by "Kodi" with any of
the following names:

KodiConfig.cmake
kodi-config.cmake

Add the installation prefix of "Kodi" to CMAKE_PREFIX_PATH or set
"Kodi_DIR" to a directory containing one of the above files. If "Kodi"
provides a separate development package or SDK, be sure it has been
installed.
-- Configuring incomplete, errors occurred!

Where should I put the source code of timidity?Or should I put the libkodi.so to timidity root directory?


Thanks!
you do not have kodi headers installed (or not in a default directory).
@wsnipex
@ironic_monkey
After I make install the timidity successfully,as follows:
Code:
[email protected]:/opt/software/audiodecoder.timidity-master/build# make install
[ 97%] Built target timidity
[100%] Built target audiodecoder.timidity
Install the project...
-- Install configuration: ""
-- Installing: /opt/software/xbmcMaster/xbmc-master/build/build/lib/kodi/addons/audiodecoder.timidity/audiodecoder.timidity.so.1.1.1
-- Installing: /opt/software/xbmcMaster/xbmc-master/build/build/lib/kodi/addons/audiodecoder.timidity/audiodecoder.timidity.so.18.0
-- Installing: /opt/software/xbmcMaster/xbmc-master/build/build/lib/kodi/addons/audiodecoder.timidity/audiodecoder.timidity.so
-- Installing: /addons/audiodecoder.timidity
-- Installing: /addons/audiodecoder.timidity/resources
-- Installing: /addons/audiodecoder.timidity/resources/language
-- Installing: /addons/audiodecoder.timidity/resources/language/English
-- Installing: /addons/audiodecoder.timidity/resources/language/English/strings.po
-- Installing: /addons/audiodecoder.timidity/resources/settings.xml
-- Installing: /addons/audiodecoder.timidity/addon.xml.in
-- Installing: /addons/audiodecoder.timidity/addon.xml
Then,what should I do?

It seems nothing happened ,when I recompiled the kodi in the /xbmc-master/build by the command "make;make apk".

Thanks!
sorry way too little context for anything to make sense. are you building for android? if so, you have to build through the add-on build system embedded in the kodi depends tree, see tools/depends/target/binary-addons, you cannot build on your system.
@ironic_monkey
Thanks very much for replying me.
Yes,I building for android.
I have extracted the audiodecoder.timidity-master.zip to the directory of tools/depends/target/binary-addons(there is only one Makefile originally).
Now audiodecoder.timidity-master and Makefile are overthere .But I seems not to be build in kodi automaticly.
Should I modify the Makefile in the tools/depends/target/binary-addons or CMakeLists.txt in the tools/depends/target/binary-addons/audiodecoder.timidity-master ?
i'm not entirely up to snuff no the android procedures, but i believe you build depends. then you build addons. then you build kodi. then you build the apk and it will bundle everything. i'm sure it's all described in docs/README.android.
@ironic_monkey
Thanks again for ironic_monkey.
I have built depends successfully.
But while building the addons,there is an error:
Code:
-- Bootstrapping visualization.waveform addon...
-- Installing: /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/visualization.waveform
-- Installing: /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/visualization.waveform/visualization.waveform.txt
-- Installing: /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/visualization.waveform/platforms.txt
[100%] Completed 'binary-addons'
make[3]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21/build/bootstrap'
[100%] Built target binary-addons
make[2]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21/build/bootstrap'
make[1]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21/build/bootstrap'
--
-- ---- Configuring addon /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/audiodecoder.2sf/audiodecoder.2sf.txt ----
--
-- ---- Configuring addon /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/audiodecoder.dumb/audiodecoder.dumb.txt ----
--
-- ---- Configuring addon /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/audiodecoder.fluidsynth/audiodecoder.fluidsynth.txt ----
--
-- ---- Configuring addon /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/audiodecoder.gme/audiodecoder.gme.txt ----
--
-- ---- Configuring addon /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/audiodecoder.gsf/audiodecoder.gsf.txt ----
--
-- ---- Configuring addon /opt/software/xbmcMaster/xbmc-master/cmake/addons/addons/audiodecoder.modplug/audiodecoder.modplug.txt ----
CMake Error at CMakeLists.txt:406 (message):
  audiodecoder.modplug: invalid or missing addon source directory at
  /opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/audiodecoder.timidity-master/audiodecoder.modplug


-- Configuring incomplete, errors occurred!
See also "/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21/CMakeFiles/CMakeOutput.log".
make[1]: *** No rule to make target `supported_addons'.  Stop.
touch .installed-arm-linux-androideabi-android-21
make: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons'
[email protected]:/opt/software/xbmcMaster/xbmc-master/tools/depends#
[/code]

What does this mean?
CMake Error at CMakeLists.txt:406 (message):
audiodecoder.modplug: invalid or missing addon source directory at
/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/audiodecoder.timidity-master/audiodecoder.modplug


This,maybe should not I put the "audiodecoder.timidity-master" into the /opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/.
@ironic_monkey

As the direction in the docs/README.android :
[email protected]:/opt/software/xbmcMaster/xbmc-master/tools/depends# make -C target/binary-addons ADDONS="audiodecoder.timidity"

There is an error:
Code:
make[4]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21'
[ 48%] Built target p8-platform
make[4]: Entering directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21'
Scanning dependencies of target kodi-platform
make[4]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21'
make[4]: Entering directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21'
[ 51%] Creating directories for 'kodi-platform'
[ 54%] Performing download step (git clone) for 'kodi-platform'
Cloning into 'kodi-platform'...
fatal: reference is not a tree: c8188d82678fec6b784597db69a68e74ff4986b5
CMake Error at /opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21/build/kodi-platform/tmp/kodi-platform-gitclone.cmake:65 (message):
  Failed to checkout tag: 'c8188d82678fec6b784597db69a68e74ff4986b5'


make[4]: *** [build/kodi-platform/src/kodi-platform-stamp/kodi-platform-download] Error 1
make[4]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21'
make[3]: *** [depends/CMakeFiles/kodi-platform.dir/all] Error 2
make[3]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21'
make[2]: *** [CMakeFiles/audiodecoder.timidity.dir/rule] Error 2
make[2]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21'
make[1]: *** [audiodecoder.timidity] Error 2
make[1]: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons/arm-linux-androideabi-android-21'
touch .installed-arm-linux-androideabi-android-21
make: Leaving directory `/opt/software/xbmcMaster/xbmc-master/tools/depends/target/binary-addons'
The error is: "fatal: reference is not a tree: Commit:c8188d8."
But I can see the Commit:c8188d8 by browsing the website https://github.com/xbmc/kodi-platform/commits/master.
Pages: 1 2