Kodi Community Forum

Full Version: accessing tp-link drive with smb keeps prompting password
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When I try to connect from Kodi Krypton (which is installed on an rpi3), to my network drive (which is connected trough usb to my AC1200 router) using smb, (resulting in a smb:\\tplinklogin.net\volume1) I keep getting prompted for my password.

I have tried connecting to it from my pc, with the same user/password, which works fine. Also using UPnP works fine. (But you don't seem to be able to set your sources as TV-Show / Movies / Music, when you do that)

On the fora, I found some references to other people having a similar problem when trying to connect to a windows share, (having to create a new user) but in my setup there should be no windows system involved. None the less,I also tried changing the password for the shared drive on the router, to no avail.

Does anyone have any idea what I'm doing wrong? Or can anyone tell me how to properly set up sources from UPnP?
Have you tried connecting to source via direct IP, i.e. smb:\\192.x.x.x\share?