Kodi Community Forum

Full Version: Scripts don't show in list?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I recently setup a Ubuntu box for XBMC Linux, and everything seems to be working great. However, when I go to Scripts, there are only 2 items listed:

.svn
windowexample.py

I found this strange, because there are numerous scripts in my ~/XBMC/scripts directory. I also tried adding a couple of scripts that I use on my Xbox (Apple Movie Trailers and iTunes Radio), but they don't show up in the list.

I even tried browsing the directory using File Manager in XBMC, but it also only shows an incomplete directory listing (there are a couple of .rars, a .zip, and a .png). I also verified that it's looking at the correct directory by renaming the test.png file using the Linux file browser. This change was properly reflected in the XBMC File Manager.

What's going on here? It's as if XBMC can't see the other files in the directory. The ownership and permissions seem to be the same among all the files, so I can't understand why XBMC can't see most of them.

Please help.
Hi, are you sure you are looking in the BUILD/scripts dir?
where the xbmc is built as default?
Maybe I did something wrong during the build process, because it didn't create a BUILD subfolder in XBMC/ (I thought that seemed a bit strange). It just seemed to build directly into the XBMC/ folder. You think this is the problem?

I'll try doing a fresh build later on, unless somebody has any other ideas.

Thanks
I've done a fresh build and now scripts seem to be showing properly.

Thanks