Kodi Community Forum

Full Version: Music Playlist can't find next item to play
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi you all,

Suffering a problem with music playback.

Normally when you start a song in an album, it plays the next song automatically (yes, the setting is enabled).
But not any more. You see KODI going over the files, but it fails to play any of the remaining songs.
When I manually click on the next song and the next and... it sometimes plays fine (like in this log file),
but sometimes KODI won't play anything anymore after the first song (can't seem to reproduce this today, so no log) and I get the error 'Item failed to play'.

Already tried to clean and update the music library (in order to get all the links right)

Any help is welcome. Hardware specs in my signature.
All my files are on a WD Live NAS device.

Ok, I think I solved it myself.
Removed all music sources in KODI and cleaned the library
Deleted all the files manually in the userdata folder that has any connection with the music DB
Add all my music again in KODI and add to library

Works fine for now, perhaps with the migration from 16.2 to 17.0 there were some bad links left in the code somewhere somehow...
So, no, this is NOT solved.

Same problem. I Can select one song, but KODI won't play any files after.
I can click on another song of the album, but again KODI won't play the next file.
And you can see that KODI tries to play it: you see KODI scrolling over the following songs, but they won't play.

So any help is still welcome, I can only play one song at a time...

new log file from today:

Today I got 4 songs!!! and then it 'broke' again... (= same problem as described above)

I tought maybe it could be the playlist time-out, cause the last song it played was over 9min.
But then I reboot the system and tried a mix-CD where no song was longer then 3min (so my NAS definitly didn't go to sleep or silent mode) and it went 'broke' after 2 songs...

I really can't see any logic in this problem.

So again: any help is welcome.
Sorry to be ingnoring you, but I don't know the answer. I'll see if the player guys understand what would cause the errors you are getting in the log.

Can you enable debug please, and try to play an album, then post that log
What happens when you remove your advancedsettings.xml?
@ DaveBlake:
No problem, can't figure it out myself. I can't put my finger on it what it causes.
Wow, I thought debug logging was enabled... woeps sorry...

@ helta
I removed the advancedsettings.xml: I'm already at track 9, a new record. But I'm very carefull optimistic.
But my movies stop constantly without the advancedsettings.xml, it's a buffering issue...

At first instance I think the problem is caused by the advancedsettings.xml. When I remove it, the CD seems to play fine. When I insert it, after 2 or 3 tracks it's done.
I made a debug log with the advancedsettings.xml, cause I kind of need it for my videos to play well.

Seems like they changed the playlist behaviour in K17. Seems to me before when you click on an album cover in the library then click on the first track it would play the first track then continue on and play the rest of the tracks as well. Now it just plays the first track and stops. To play the whole album you have to go to the info screen then click the play button there. Driving my GF crazy as she can never remember how to get into the info screen.

So not sure if it's quite the same problem, but it's quirky and trickier to play an album now. There may be something in the config I'm missing, but so far can't get it to play albums like one would expect it should.
Make sure that "Play next song automatically" is enabled and that "Queue songs on selection" is disabled.
Ah ha! Queue songs appears to have been the problem. Thanks for the tip.
@Zokkel - I was having a similar issue and, in my case, it seems to have been resolved by reducing the cache size. If you're still having this problem, you may want to try different values in advancedsettings.xml. I'm currently using the following but a different size may work for you.

With your settings albums play just fine, but music folders (with a lot of files in it) not: it skips +-20 songs and then resume, after the song again skipping +-20 songs and then resume.
The movies play fine if I don't pause. If I pause, they stop buffering. When resume, it only plays the rest of the video that was buffered and stops.

My only solution that works at the moment: <memorysize>0</memorysize>
And with a SSD, that is not recommended, but hey, at least I can listen and watch videos without unexpected stops.
Same problem. It's breaking google play music and pandora in addition to the music library.