Kodi Community Forum

Full Version: Issue with MP4s with QuickTime timecode
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Apparently Kodi has an issue with handling mp4 files that are using QuickTime time code.

This was also discussed already a year ago in OpenElec forum:
http://openelec.tv/forum/72-xbmc/77849-g...ack-issues

Problem
I tried to display some videos my son did with his GoPro Hero4. I tried various Kodi versions, including latest alpha version, on Windows and Raspberry platform and all are behaving the same.
The video starts for 5 seconds and then it stops for ~ 30 seconds. Then it continues to play without any further interuptions, but with an audio delay (difficult to identify because of the video content).

Fix
It seems that OpenELEC/Kodi can not handle the "QuickTime TimeCode" > listed at the end in your Media Info. I am not an expert in this. My last step was to use "MKVToolNix GUI" to remux a original GoPro video without any changes. The result did not contain the two "QuickTime TimeCode" parts in media info. The remuxed file runs fine > without a stop at the beginning !!

So Im wondering if its some kind of feature that cant be fixed in Kodi video proccessing or there have not been enough people who have encountered that issue?