Kodi Community Forum

Full Version: EMINENCE 2 MOD (REVIVED)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
He appears to be talking about the "information" screen. It was a bit confusing because he missed the word the.

The information screen is the window that comes up that shows extra information about an entry, you can view the plot re scan the item view actors ect.
So I have basically finished the first new view layout you can see a preview below:

Image

If you disable the clock in the header it will be disabled in this view as well. All fonts and colors are taken from the skin itself and are not custom. Therefore custom color settings in the skin options will work as you would expect. The unwatched count () only displays if >0.

The one thing I have not yet started is trying to make a "navigation aid" I am not sure what it is called exactly. Basically a helper thing that aids when scrolling though the list of shows. On my test system I only have a few shows but I need to load like 1000 shows for testing. The info will display at the top right of the fan art image. Data will be something like currentItem#/Total Items there should also be a thing for the year if sorting by that or letter if sorting by that something so you can tell where you are.

If anyone has idea idea of what function names I need to look into please let me know. Alternatively some sample code of a similar thing from somewhere that I can read would be good.

Anyways, please post thoughts on the new view mode and any major issues that appear to exist at this stage.
(2017-09-22, 13:39)PX80/Alanon Wrote: [ -> ]I have a poblem that cache folders of certain AddOns doesnt update. I dont know how to delete/refresh the cache. any ideas?

Example: I am using the Amazon VOD Addon and my Watchlist never syncs with the Website when using the shortcut via the skin, so i need to call the PlugIn and then use its navigation to find a updated version.


Hm... cache is always tricky. The best and safest thing you could do is purge the specific add-on userdata folder in hopes that that would snap it from whatever is clogging its proper behaviour. That way, even if you screw something up, it's only that one add-on that went belly up. If you're careful and research what to remove, you can keep your logins and whatever settings the add-on has, while only removing the contents, which should trigger an update and bring the function back.

@Alanon: could it be that simplecache.db is not pulling updates but use the cache instead?

I have raised the question with marcel -> 322101 (thread)


Question: Do you know if i can force the Eminence Mod 2, not to use the simplecache.db for certain folders? Just need to know where its implemented

--> https://github.com/marcelveldt/script.mo...implecache
Too many posts to quote...

@Razieal121: Pressing "i" leads you to the extended info, which defaults to the information available in your database. There used to be an option for searching the item directly in the add-on, but it broke a while ago on some skins, and I'm not sure if the behaviour was fixed. If you're not getting anything after pressing the button, its most likely a database error, in which case you're probably getting an Extended Info error in your logs. I can confirm that it works for me.


@ZERO <ibis>: Nice work (And fast!)

From what I can see on the image, I have a few potential nitpicks and pitfalls for you to consider:

1. The plot text could be justified (if you built the entry yourself, you should also check for the plot outline setting). IMHO, it just looks nicer.

2. There are no flags or next aired info - I personally don't really need either, but many folks like them, a lot. I'm not criticising, mind you. I simply think that for many it might be a worthwhile addition if you find an elegant enough solution which is agreeable with your ideas for the view.

3. You probably need to test the view-type out on various content types - tv shows, seasons, episodes, movies, videos (the youtube add-on will do fine), etc. to make sure that the view is compatible with them all. Some items will have specific needs of the flags and other info displayed. If you want to limit the view on certain types only, that fine with me.

4. Another thing worth keeping in mind - how does the view do on the light skin theme? Do the background colour settings or other customisation options affect anything in the view, etc.

5. Regarding your question - the skin already has a classic scrollbar and an alphabet scrollbar (you can see the way they work in other view-types). So you can add one or both by either including the proper names in the file or by copying the code and adjusting the positions or behaviour. Due to the specificity of the view, I'm guessing that the later will be necessary.

6. A thought perhaps worth considering - there was a landscape-like image you originally posted as a separate view-type. It might be best to include that design within the same view you're building, just as a separate layout for video and episode content. I've done something similar with the right list, and the big poster view is similar as well. There's really not a great advantage of that layout for films or seasons, unless you want to do exactly as the skin has, and substitute it for logo or clearart images.

@PX80: I don't believe that a skin can do that at all. It would need to know how to execute commands on a much more advanced level. My guess would be that it's all in the add-ons.
Thanks for the quick reply and suggestions, will be working on those.

1) Will do! *Have now tested, not sure about this yet, I have some examples in my testing that look bad justified but maybe I just need to get used to it. I will do some more testing, my main focus is to ensure easy speed reading.

2) I assume you mean the content of ?$VAR[Label_ExtraInfo_Icons]? I can add another line if there is an existing way to toggle it on/off in the settings. That extra stuff takes away from easily reading the plot. If you let me know the exact var name and setting switch I can toss it in there no problem.

3) As for the view I only only intend it for TV shows when I am finished with the view I plan to apply the appropriate restrictions during the final code clean up step.

4) I have not tested this yet, I assume users of the light skin would want the black side menu to de a lighter color. I will test and see how this other view mode effects other parts of the skin and code a switch for it to maintain compatibility with the light skin mode. (is Skin.HasSetting(darkoverlay) the proper check for this?)
*Yea you can not read the right side menu, I need to know what the detection switch for the light mode is so I can build a response for when it is on. Otherwise the only way to fix it would be to make the lightshadows required to use this view mode with the light skin mode.

5) Ah I see Object_Scrollbar_Alphabet and Object_Scrollbar I will do some testing with those. *Realized my issue was not turning them on lol

6) Interesting, you are saying there is a way to have that other view type just part of this one but automatically display only when viewing the episode list. I suppose the way to do that would be to build a second control under my main important and then set each to have the related target viability parameter.

Thanks for the help!
I got the separate view to show up but due to the tiles being a different size I need <focusposition> to be a conditional setting but so far I have not been able to make it work that way. This is currently where I am stumped.
Basically finished it in the week the server was down but I got a few things I am stuck on.

Still need to know how to detect when the light theme is active so I can have it play nicely with that mode.

I need to know how to get extra fan art images to load. (in general, this is not really an issue with my code but an issue of me trying to figure out literally how to get them to load in the skin at all, via the extrafanart folder)

I notice this skin appears to be lacking some of the media info icons, if possible I would like to add some so I can display this data via the appropriate icons for files. I would build this into the include file so the methods could be used easily by others.

I plan to post some pics up on Monday.
(2017-10-07, 01:25)ZERO Wrote: [ -> ]Basically finished it in the week the server was down but I got a few things I am stuck on.

Still need to know how to detect when the light theme is active so I can have it play nicely with that mode.

I need to know how to get extra fan art images to load. (in general, this is not really an issue with my code but an issue of me trying to figure out literally how to get them to load in the skin at all, via the extrafanart folder)

I notice this skin appears to be lacking some of the media info icons, if possible I would like to add some so I can display this data via the appropriate icons for files. I would build this into the include file so the methods could be used easily by others.

I plan to post some pics up on Monday.

Sorry for the late reply, wasn't sure if the site was back on-line. 

As far as the theme, I usually make a separate setting, background or colour if necessary and add "String.IsEqual(Skin.CurrentColourTheme,SKINDEFAULT)" or "String.IsEqual(Skin.CurrentColourTheme, Light)" as a visibility condition.

Extrafanart is part of the "Image_Background" variable. It contains a series of conditions meant for almost everything connected to backgrounds, including the skin systems for handling extrafanart provided by Skin Helper and Artwork Beef. That variable, in turn, is included in the "Furniture_Background", which provides a multiimage control. The idea is that if you integrate the view into MyVideoNav.xml, Includes.xml, etc, it should carry the existing systems in place along with it with no need to specify anything in the view itself, as the videonav contains the furniture underlay already. However, if your view-type decreases the dimensions, it might be necessary to copy over the multiimage code and do something different with its dimensions.

As far as the icons are concerned, we're talking flags and icons and such? I'm crap at making them, so that's why there aren't more of them. If you have the skills, by all means, include anything that you see fit to make. My only qualm would be to try to mimic the style, colour and AR of what's there, so as to remain as uniform as possible.
Hey guys,
Spent some time setting up this skin on my ageing rPi2 modelB, runs fairly well overall (tweaking it for best performance etc)

--having an issue getting it to display TVSHOW and MOVIE logos though:
- selected tv show logo viewtype, nothing showing
- when I run Artwork Downloader program Add-On, I'm given options to download fanart amongst other things, but no option to find/download a logo (or clearart) --and the initial scraping of the movies/shows obviously didn't grab them either.

Any ideas?
(2017-10-07, 22:45)PantsOnFire Wrote: [ -> ]Hey guys,
Spent some time setting up this skin on my ageing rPi2 modelB, runs fairly well overall (tweaking it for best performance etc)

--having an issue getting it to display TVSHOW and MOVIE logos though:
- selected tv show logo viewtype, nothing showing
- when I run Artwork Downloader program Add-On, I'm given options to download fanart amongst other things, but no option to find/download a logo (or clearart) --and the initial scraping of the movies/shows obviously didn't grab them either.

Any ideas?

That's strange. If you're just setting up, it could be that the public fanart.tv APIs are paused due to overload. If the Downloader can't retrieve the artwork and it hasn't been cached previously, that might be the cause, in which case the problem should self-correct in time.
(2017-10-08, 00:19)Alanon Wrote: [ -> ]
(2017-10-07, 22:45)PantsOnFire Wrote: [ -> ]Hey guys,
Spent some time setting up this skin on my ageing rPi2 modelB, runs fairly well overall (tweaking it for best performance etc)

--having an issue getting it to display TVSHOW and MOVIE logos though:
- selected tv show logo viewtype, nothing showing
- when I run Artwork Downloader program Add-On, I'm given options to download fanart amongst other things, but no option to find/download a logo (or clearart) --and the initial scraping of the movies/shows obviously didn't grab them either.

Any ideas?

That's strange. If you're just setting up, it could be that the public fanart.tv APIs are paused due to overload. If the Downloader can't retrieve the artwork and it hasn't been cached previously, that might be the cause, in which case the problem should self-correct in time.






PANTSONFIRE wrote:
--apologies, I need to correct myself.
Thanks for your suggestions. I think the problem was that I hadn't allowed enough time for the system to display the icons (MEDIA INFO 3 view). --when I hung around long enough, all came correct.

-however, I need to amend what I originally wrote. The problem I'm now having is that the logos aren't showing up in LOGOS LIST view, or LOGOS WITH FANARTS/THUMBS view (no matter how long I hover over each item).
@PantsOnFire: Basically, you need to keep in mind that there are two ways of maintaining the artwork - either locally, or directly inside the Kodi cache. In the first case, Artwork Downloader will download the artwork locally, and Kodi will cache the images from there, and everything should be faster. In the second, the tool will only update the database with the links, leaving Kodi to fill in the blanks and download the artwork as accessed. Depending on the size of the library, server status, etc, it can take a very long time before everything is displayed properly. In theory, Kodi should start the download process for an item when you first view it and begin retrieving the logo, clearart, backgrounds, etc. Scrolling through the library can often confuse the process and clog up everything, preventing the fetching process. Generally speaking, there is no rule as to what gets downloaded when or how fast the cache gets updated. 

For example, there should be a logo displayed on the top of the screen next to the clock, even in Media Info 3. If you can see the logo there but not on the other two views, then we're probably dealing with a bug. If you can't see logos at all, then its probably still an issue with the retrieval itself. In either case, there should be errors in the log detailing what happens when Kodi tries to access those images, either by downloading them or by trying to display them. A definitive solution to this issue would be to use something like the Texture Cache Python utility and force artwork caching into the Kodi database, which should resolve most of the issues. Otherwise, you're at the mercy of Kodi's caching mechanisms. From the behaviour you've described, it seems to me that Kodi is still trying to download and cache the artwork. I've had these protracted loads whenever I had reset my library, which is how I discovered the Python utility in the first place.
So here is two pics of the latest versions of the views still being worked on:
Image

Image
I think I found the issue I was having with loading the extrafanart. The problem is that I need to figure out how to load the art into Kodi directly. What I have is images in a file called extrafanart in the same directory as the related TV show. I need a way for Kodi to scrap these images, does anyone know how?

Ok after looking more into it there is no way to actually load that into the database. Instead I will add support via <imagepath background="true">$INFO[ListItem.Path]/extrafanart</imagepath> for those who have this folder.
(2017-10-09, 16:47)ZERO Wrote: [ -> ]I think I found the issue I was having with loading the extrafanart. The problem is that I need to figure out how to load the art into Kodi directly. What I have is images in a file called extrafanart in the same directory as the related TV show. I need a way for Kodi to scrap these images, does anyone know how?

Ok after looking more into it there is no way to actually load that into the database. Instead I will add support via <imagepath background="true">$INFO[ListItem.Path]/extrafanart</imagepath> for those who have this folder.

If you don't use the Image_Background variable, many skin background features won't be available. What you have described is the proper behaviour of Artwork Downloader local library artwork. However, the users who did not download the artwork locally, or use Artwork Beef won't have those specific folders and won't be getting their artwork displayed. Skin Helper detects the various alternatives automatically, and the proper code is already included in the mentioned variable. So simply replacing the infobool you named with $VAR[Image_Background] should switch you over to the skin track. If you've set everything else up properly, it should just work.