Kodi Community Forum

Full Version: Kodi crashes when trying to watch a channel
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
After upgrading from Kodi 16.2 to 17, I can't watch any channels from the live TV. The EPG and channels show up fine, but when I go to select them it loads for a second or two and then it crashes. None of the settings have been changed since 16.2 where it worked without any issue. I have attached debug logs from two systems, both based on Ubuntu 16.04 LTS kernels. I can browse the file shares in file manager of the ArgusTV file shares so I don't think the permissions are an issue.


Hi i have the same problem here. On two Linux Laptops with Ubuntu 16.04.2 and Kodi 17 with argustv pvr fresh installed, Kodi 17 will crash if i switch to a channel. Both HD and SD. The Channel List and the EPG are loading fine and i am able to watch my recordings. On a third Laptop with Ubuntu 14.04 and Kody 17 id works fine. Are there Problems with Ubuntu 16.04.2 together with Kodi 17 and ArgusTV?

If i start kodi from the terminal, after the crash there stands following in the terminal:

/usr/lib/x86_64-linux-gnu/kodi/kodi.bin: symbol lookup error: /usr/lib/x86_64-linux-gnu/kodi/addons/pvr.argustv/pvr.argustv.so.2.5.4: undefined symbol: _ZN7ArgusTV9CTsReaderC1Ev

someone any idea??
I think I had that issue when it was trying to use the wrong libjsoncpp file. Make sure the libjsoncpp.so.0 is linked to the 0.6.0 file and not the 1.7.2 in /usr/lib/x86_64-linux-gnu folder. I remember the repo or something was wrong, I had to copy a file from my other box to get it to work. For reference my SHA1sum hashes are:

0f31f0c06d20063f9b5a2e3e1985d512cfa6159b  /usr/lib/x86_64-linux-gnu/kodi/addons/pvr.argustv/pvr.argustv.so.2.5.4
5bc2c3e983264ee5b85d3ff1b9c251e17b0cb9e4  /usr/lib/x86_64-linux-gnu/libjsoncpp.so.0.6.0

I've been wrestling this for days. Kodi doesn't generate a crash log or think it's crashed. I even re-did the samba shares for the recording and livestream folders, and again the recordings work fine but the live stream does not.

I even set up NextPVR and still couldn't get anything to stream. I do have older models of the HDHomeRun (HDHR3-US) and I know that they dropped support for the HDHomeRun protocol in Jarvis, but using a backend PVR shouldn't affect that issue. Totally at a loss here
(2017-03-06, 23:40)mAwAm Wrote: [ -> ]/usr/lib/x86_64-linux-gnu/kodi/kodi.bin: symbol lookup error: /usr/lib/x86_64-linux-gnu/kodi/addons/pvr.argustv/pvr.argustv.so.2.5.4: undefined symbol: _ZN7ArgusTV9CTsReaderC1Ev

So I decided to run Kodi from terminal to get console messages, and this is the same one I have. So we have the same issue.

I installed Kodi on a Windows 10 box (both 17 and 17.1RC1) and ArgusTV works just fine on that platform. Going to see if I can trace what's missing in the argustv plugin on Linux.
The krypton branch of the source compiles to pvr.argustv 2.5.5 and not the 2.5.4 that's in the repo, and it works. I also upgraded to 17.1RC in the process. These are the instructions I followed:

git clone -b Krypton https://github.com/xbmc/xbmc.git
git clone -b Krypton https://github.com/kodi-pvr/pvr.argustv.git
cd pvr.argustv && mkdir build && cd build
cmake -DADDONS_TO_BUILD=pvr.argustv -DADDON_SRC_PREFIX=../.. -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX=../../xbmc/addons -DPACKAGE_ZIP=1 ../../xbmc/project/cmake/addons

Then replace the binaries and addons in the appropriate folders, eg /usr/share/kodi/addons/pvr.argustv, /usr/share/pvr.argustv, /usr/lib/x86_64-linux-gnu/kodi/addons/pvr.argustv, etc where ever they are. Not sure what was wrong in the 2.5.4 addon but it seems it was fixed with 2.5.5.

Now the wife can stop complaining Wink

edit: Also I said above NextPVR wasn't working, but it did I just had the backend configured incorrectly.
Thx a lot!! You made my day!

I tried the same from: https://github.com/kodi-pvr/pvr.argustv

but the build instructions failed. With your instruction it succeeded.

Thank you! Thank you! Thank you!