Kodi Community Forum

Full Version: Internet Certification Fail - Google Play won't load
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone,

I hope you can help.

I'm trying to update Jarvis to Krypton on my android box. I've gone into google play and it won't load. Just a white screen.

Tried going onto the internet and a pop up box keeps popping up saying the security cert. has failed. I clicked continue a load of times then downloaded the .apk file from kodi. No pop up to say download completed though. Then went into downloads in the file browser and it said there was a parsing problem.

Searched around and saw suggestions to manually set the time. Tried that. Also tried the auto update time. Didnt work either. (GMT as Im in the UK)

Strange thing is that the streaming seems to be working fine via kodi.

Ps yes the wifi is fine.

Please help!

Thanks in advance

What version of android does that box run?
It's 4.4.2

Thanks in advance for you help
Yes well, Kodi 17 requires at least 5. This is your problem, and is well announced in the release notes for 17.