Kodi Community Forum

Full Version: MP4 video don't playback anymore after upgrade to 17.0
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all, i', asking for help because i don't know anymore how to debug this.
i've a PC x86 platform with the installation of the old 15 kodi ISO version, so linux based, ubuntu, kodi and Lubuntu desktop, Nvidia graphic with 303 driver installed.
i've keep the system upgraded few time a year, so yesterdey i've made the upgrade from 16 to 17.0 krypton, using packet manager from lubuntu, searching all new package and installing it.
i found that all it works good, i've ripristined confluence skin to have it working same as before, the system asked me to identify again the direcory for film and tv series and redo the scan, i've played a few pieces from films and similar in AVI, all working well...
until i've tried to play an MP4 video.
when i've tried it, what i've seen is a flickering image in primary color, and after it a black screen, but i continue seeing the voices and sound of the video.
trying to giv a "0" command to see what codec are doing give me no data, because the only thing that i can see is a "00:00" output, that i can't interpret (maybe the video still remain on the first frame?)
consider that from the selection interface i can see the picture grabbed from the video as a thumbnail.
i've tried to see if it can be a graphic driver problem, so from lubuntu i've installed VLC that show me the MP4 videos perfectly.
it cannot be a permissione problem because the same files was perfectly read from version 16.
it keep the same behaviour independently from what point in the interface i use to come in (video, tv shows, film)
the only other strange thing (but is an old problem that i have still from 16 version) is that when i reboot the PC, the image presented of kodi interface is 1/4th of the screen (i've an optoma video projector connected on HDMI1) and 've to go to settings - video - output and switching ftom default to HDMI1 (or vice versa) to have the correct full screen image.
i'm quite desperate because the majority of our videos are in MP4...
can someone give me some hint to investigate?
some solution that i'vent found?
it's impossible that the problem is in the kodi codec for mp4, it's integrated in kodi himself, so some million users haven't to see mp4 anymore....
please, help :-(
Quote:flickering image in primary color, and after it a black screen, but i continue seeing the voices
Can you try software rendering, the big diff between VLC and Kodi is that the default for VLC is software rendering. A proper debug log posted to a public pastebin and that URL linked back to this thread might offer additional information.
can you tell me what log may be useful to post?
Debug log (wiki). <--- click me

Upload it to PasteBin.com or a similar site and supply their link here. Please do not post logs directly here.
first of all, sorry but i give you wrong info. too much time that i don't open this pc.
my system tell me that it use a Intel Mesa DRI haswell onboard gpu, wirh opengl 3.0 mesa 10.1.3 driver
LSPCI agreed with him:
vga compatible controller intel corporation 4th generation core processor family integrated graphics controller v.6.0
what i don't know is why i have a Nvidia Xserver settings app installed at this point. i'll go to find the debug log. thanks
here the logs:
https://paste.ubuntu.com/24165728/
thanks for your support
You need also an uptodate vaapi:

sudo apt-add-repository ppa:wsnipex/vaapi
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install i965-va-driver


afterwards post:
vainfo | pastebinit
done, thanks for your help, here the pastebin
http://pastebin.com/yY3GWBWP
unfortunately the problem persist also with the i965 driver installed :-(
Nope that did not work. You still have an old vaapi driver.
Try:

sudo apt-add-repository ppa:wsnipex/mesa
sudo apt-get update
sudo apt-get dist-upgrade
tried from remote site, and i suspect that something has horribly goes wrong, because at now vainfo respond
error: can't connect to X server!
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 1
libva error: va_getDriverName() failed with operation failed,driver_name=i965
vaInitialize failed with error code 1 (operation failed),exit

hope to see X server working when i arrive home tonight...
ok, verified from local.... and something very strange happens.
Kodi is working well, i can see MP4, MKV, AVI ando so on, i still have the old problem of displayistarting at 1/4 of the monitor dimension (but i'm used to this and it requires only to select default vs HDMI1 in system - screen to resolve)...
but i've got a lot of trouble entering lubuntu.
i had to reboot twice, and give the exit command 4 times to finally view the login interface and choose lubuntu.
here is my new vainfo output http://pastebin.com/a6HCK63B
but hey, i can see again my video, so this is a very good news at now :-D
thanks a lot to everyone