Kodi Community Forum

Full Version: Enable complete instead of forced subtitles by default
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have a small problem with Kodi (Windows 10, 17.0) settings, and I hope someone here could answer my question :

I have .mkv files with embeded subtitles. The subtitles are in the following order:

1. French Forced
2. French Complete

Kodi automatically enables subtitles, which is good. But unfortunately, it is the first (forced) track that is enabled by default. Is there a way to set up Kodi so it enables the complete track by default instead of the first one?

Thank you for your help.
Sometimes it's the reverse, just a matter of the encode. MKVmerge will make fast work of this issue, allowing you to set the default and order of subtitles. MKVToolNix (wiki)
Thank you for your quick answer. I will use MKVmerge to solve this problem.