Kodi Community Forum

Full Version: Argus TV client on Android / Amazon Fire
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have an Argus TV back end that has been working well for 18 months. The client is currently running on a Raspberry PI connected to the network via Ethernet. I also have a Windows Kodi client, this is all working great.

I now have an Amazon Fire TV connected directly to a TV. I don't have Ethernet in that area so its connecting over WiFi. I cannot get it to work. I can pull up the channels and it acts like its playing but there is no video, and no sound.

I have also tried this on other android devices with the same result. Below is a partial log:

12:52:17.175 T:520286225488   DEBUG: AddOnLog: ARGUS TV client: CEventsThread::HandleEvents
12:52:17.175 T:520286225488   DEBUG: AddOnLog: ARGUS TV client: CEventsThread:: ARGUS TV reports event LiveStreamStarted
12:52:17.176 T:520511026256   DEBUG: CurlFile::ParseAndCorrectUrl() adding custom header option 'Content-Type: application/json'
12:52:17.177 T:520511026256   DEBUG: CurlFile::Open(0x7937f5f900)
12:52:17.207 T:520867542096   ERROR: AddOnLog: ARGUS TV client: MultiFileReader: can not get stat from buffer file smb://WINSERVER/Recorded TV/Card1-1-0.ts.tsbuffer.
12:52:17.207 T:520867542096   ERROR: AddOnLog: ARGUS TV client: CTsReader::OpenFile failed.
12:52:17.207 T:520867542096   DEBUG: AddOnLog: ARGUS TV client: Delaying 200 milliseconds.
12:52:17.226 T:520511026256   DEBUG: AddOnLog: ARGUS TV client: CKeepAliveThread:: KeepLiveStreamAlive returned 1
12:52:17.407 T:520867542096    INFO: AddOnLog: ARGUS TV client: Opening live stream took 2799 milliseconds.

I suspect the issue is with the smb://WINSERVER... I am using the same login credentials on this client as the working clients.

I can put up the whole log if that would help. I'm hoping someone has some thoughts on this, I've already burned way too much time trying to get this to work. The Argus TV forum appears to be dead...

Thanks for any help.


So, I've had to pull the plug on Argus TV. If anyone comes across this and is interested, I put WMC on an old laptop and installed ServerWMC on it. Kodi running the WMC PVR client is so far working well on the Amazon Fire, and is even working over WiFi. I did dedicate an older wifi router to just the Amazon TV box, but so far things look good.

EDIT 2: It Works!

I'm running on Windows Server 2012 and SMBv1 appears to have been disabled. That was not a problem on the Raspberry Pi, but appears to be an issue for Android. Enabling that and putting the user:password in the smb path did the trick.

The details:
To enable SMB1 run the following command in a powershell window:
set-smbserverconfiguration -EnableSMB1Protocol $true

Your smb path should look like this (settings/File Manager/add source):

You may also want to match the case of your server. I entered this lower case and it did not work. I entered again matching the case on the server and it did. So if your server is ARGUS and your share is Recorded TV and your user name is tom and your password is brady then your path will be:
smb://tom:brady@ARGUS/Recorded TV