Kodi Community Forum

Full Version: "1 item failed to export"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Thank god for my ultra fast M2 SSD drive setup or this would have taken hours... kept exporting over and over until it finally didn't crash and it produced the "1 item failed to export" error.


08:29:15.593 T:8548 ERROR: CVideoDatabase::ExportToXML failed, exception: bad allocation
(2017-05-23, 15:32)Tyrindor2 Wrote: [ -> ]08:29:15.593 T:8548 ERROR: CVideoDatabase::ExportToXML failed, exception: bad allocation

That means for some reason Kodi couldn't allocate memory (RAM).

Have you exported to a single or multiple files? If single please try again with exporting to multiple files.
Please also try it with a library which only contains the suspicious TV show.
I have 32GB of RAM, so if it's crashing it'd have to be because the program is 32bit limited. Though, I tried the new 64bit nightly builds and still happens.

I did multiple files, and it failed to create tvshow.nfo under the same show, One Piece, while everything else is fine.

Here's a log where it crashed on "exporting one piece".. i'll have to run it multiple times to get one where it doesn't crash:
Yes, it still happens with just that show.

Here's my video database with just that show, should be easy/fast to export it and maybe you can figure out why it is crashing/producing that error when exporting. Happens for both single file and multi files.

Well i'm at a loss of words, when it's "crashing" it's actually doing something. With the multi-file export I can see it slowly but surely adding NFOs for every episode. It just takes forever, like 30 minutes for the entire show! And here's the kicker, it exports it correctly as long as you wait and as long as it doesn't error out with a bad allocation error.

EDIT: It seems like waiting only works for multi-file export, as this single file export has been going for ages... and it's still not responding.
This definitely seems to only affect single file export. The feature is a bit buggy. it completely ignores your watch status import settings as well, and always imports them.

If I only add season 1-8 of one piece, it's fine and exports correctly. If I add any further seasons (doesn't matter which), it's "failed to export". Super strange. There's no logging errors other than bad allocation, the program doesn't like something in this show when doing single file exports and doesn''t seem to be logging whatever causes the problem.

I think after the show exceeds a certain amount of episodes (somewhere in the ~120 range), Kodi starts to choke on something. I have shows larger than that, so not really sure why Kodi would be struggling.
I figured it out I think. It attempts to export ~128 actors per season (combine that with 19 seasons) and it's way more than any other show I know of. A total of 4,160 exported files for this single show. Even a super long show like "24", only pulls about a fourth of that. I think it's causing some memory management issue within Kodi.

Perhaps a test build that disables actor exporting with the single file method?
Copying my comment from the bug report:

I had the same issue on one TV show. By enabling 256MB of swap on a Raspberry Pi Zero, I was able to export my library successfully.

Commands I used:
$ sudo dd if=/dev/zero of=/swap bs=1M count=256
256+0 records in
256+0 records out
268435456 bytes (268 MB) copied, 20.3084 s, 13.2 MB/s
$ sudo chmod 600 /swap
$ sudo mkswap /swap
Setting up swapspace version 1, size = 262140 KiB
no label, UUID=8c7afca4-b78d-4c3e-82d0-b20292897833
$ sudo swapon /swap
$ free -m
             total       used       free     shared    buffers     cached
Mem:           352        330         22          4         20        187
-/+ buffers/cache:        122        230
Swap:          255          0        255
At this point, you can see there's already not much free memory left, only 22/350MB. I then ran the export. At the end of the export, I confirmed the videodb.xml had been created as not just a 0 byte file and I received no error or system crash which had been happening before I turned on swap. Free memory at the end of the export look like:
$ free -m
             total       used       free     shared    buffers     cached
Mem:           352        331         21          0         10         58
-/+ buffers/cache:        262         90
Swap:          255         72        183
Thanks Tyrindor2 for your forum post and bug filing, you helped me export my library. :-)
Pages: 1 2