Kodi Community Forum

Full Version: pixelation and audio loss
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I have a HD Homerun and an Intel NUC i7-5557U running Ubuntu 16.04.2 with Kodi 2:17.1~git20170320.2031-final-0xenial.

When watching live or playback recordings I get random pixelation of the image and audio corruption. I've tried a few tweaks but nothing helps.

The HDHomeRun Add-On will play without these issues. It will occasionally pause but video and audio resume without any loss of content.

Where can I start to help debug this issue? Is my hardware not up to spec? What logs can I provide?

Kind regards,
Tom
No Debug Log no issue!
Sorry, here is the link to the logfile;

https://paste.ubuntu.com/24623288/
Can you reproduce with a recording?
Hi Fritsch,

Here's the log from playing a recording:

https://paste.ubuntu.com/24633740

Thanks,
Tom
Please disable mythtv and play via File menu.
Quote:23:36:16.856 T:140567887468288 ERROR: ffmpeg[7FD882FFD700]: [mp2] Header missing
23:36:16.856 T:140567887468288 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
23:36:16.919 T:140567887468288 ERROR: ffmpeg[7FD882FFD700]: [mp2] Header missing
23:36:16.919 T:140567887468288 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
23:36:16.919 T:140567887468288 ERROR: ffmpeg[7FD882FFD700]: [mp2] Header missing
23:36:16.919 T:140567887468288 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
23:36:16.981 T:140567887468288 ERROR: ffmpeg[7FD882FFD700]: [mp2] Header missing
23:36:16.981 T:140567887468288 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)

The file seems broken :-(
Hmmm... I'll do another recording and repeat the procedure (send the logs from the file play with mythtv-backend disabled)...stay tuned!
https://paste.ubuntu.com/24655733/

I've recorded some live TV this evening but it looks like this file is also broken. What keeps breaking my recording files?

00:10:07.688 T:140086926632704 DEBUG: Thread JobWorker 140086926632704 terminating (autodelete)
00:10:38.597 T:140087283746560 DEBUG: ffmpeg[7F689CC90700]: [mpegts] PES packet size mismatch
00:10:45.506 T:140086112933632 DEBUG: Previous line repeats 19 times.
00:10:45.506 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.506 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.568 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.568 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.631 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.631 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.631 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.631 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.631 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.631 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.631 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.631 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.882 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.882 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.882 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.882 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.882 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.882 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:45.882 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:45.882 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:46.132 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:46.132 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:46.132 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:46.132 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:46.132 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:46.132 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:46.132 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:46.132 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
00:10:46.195 T:140087903827712 DEBUG: ActiveAE::SyncStream - average error 105.804204 above threshold of 100.000000
00:10:46.257 T:140087903827712 DEBUG: ActiveAE::SyncStream - average error 5.804204 below threshold of 30.000000
00:10:46.446 T:140086112933632 ERROR: ffmpeg[7F6856FFD700]: [mp2] Header missing
00:10:46.446 T:140086112933632 ERROR: CVideoPlayerAudio:Big GrinecodeFrame - Decode Error. Skipping audio packet (-1094995529)
Can you try vdr instead of mythv?
Does vdr work with HD Homerun?

apt-get installed vdr 2.2.0-5build1 but I have no idea about this program. It may take some time to get it working. The service failed to start after install.

Am I to understand that MythTV may be the cause of the corruption?
That's what we are going to find out.

Also pixelation here: http://solidrun.maltegrosse.de/~fritsch/..._h264-2.ts ?
Hi Fritsch,

I downloaded and played the file 1080i50_h264-2.ts. Absolutely no problems with pixelation or audio. Did you want me to capture a log of that?

Looks like the MythTV backend is the issue. Correct?
Hi Fritsch,

I've been trying with tvheadend - recording is better but I'm still getting some pixelation. Audio seems to stay reasonably clear. Still not 100% clear for either thing.