Kodi Community Forum

Full Version: No black bars no matter what I do!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all

I am having issues with my android box. All the videos seem to play stretched on the screen with no black bars. In order to fix this I have tried:

1. Pressing the "Z" key or changing the Aspect ratio on the menu does nothing. The title at the top changes but the image stays the same.
2. Disabled hardware acceleration and restarted the box. No difference.
3. The Minimise Black bars in the settings is on "Off" I have tried flicking it "On" and "Off" with no difference.
4. I have tried deleting the guisettings.xml however past Android/data/org.xbmc.kodi/files/ I can not see any files in file explorer. (sorry I am new to android)

This is not the first time that this happened. Last time (about 3 months ago) the only way I was able to get this working was by reseting the box to factory defaults. However I am reluctant in doing that again as repopulating the library takes forever (~10TB of content on a NAS).

Any help would be greatly appreciated.

I have attached images with the settings and with my current setup.

*Hopefully the images are OK now Smile

ImageImageImageImageImageImageImageImageImage
That is not how the imgur gallery tag works Smile
So am I alone in this? Am I doing something wrong?
Since you've got RKMC in the menus tells me you don't have an unmodified Kodi install, what you are running is an adapted version of Kodi by Rockchip, so what you see could be due to the changes they've made to the player code.
However what you could try is open the OSD go to Video settings and change View mode.
location of the Userdata (wiki) folder is likely Android/data/org.xbmc.kodi/files/.kodi/userdata/ (follow the wiki link to see note); delete guisettings.xml
Found the issue. Thank you jjd-uk for leading me on the right path Smile

For anyone else with the same issue as mine the solution is in the RKMC menu. There is a different acceleration setting Accelerate RKCodec. The second you disable that the aspect ratio goes back to normal. The playback was a bit stuttering, so I enabled the MediaCodec acceleration. All is well again!

Hope this helps somebody with the same issue as mine

Thanks for the help

ImageImage
Thread marked solved.
So, not even using Kodi!