Kodi Community Forum

Full Version: Changes to Aeon Noxhome screen keep disappearing
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I posted this in the Aeon Nox skin support section, but have had no responses. I am thinking this is not an issue with the skin but with something else (hardware or some software program) that is causing the below issue.

I am using the Aeon Nox 5 skin on my EzeeCube (which runs a Custom Yocto Linux build). After having issues with the EzeeCube and basically resetting it to factory default, I reinstalled the Aeon Nox 5 skin and my add-ons and apps. I re-did all the custom home menu items I previously had. I separate the kids stuff into separate menu items like Cartoons, Kids TV, Kids Movies, etc. After setting all that up along with the sources, everything works fine for a bit. But sometimes when I go to use my EzeeCube, I find that the skin has reset. My custom items are gone, the menu bar is back to the middle of the screen, and the default home menu items are back. All the paths still exist, but I have to set up my custom items again. I tried using Backup to backup the skin settings, but it never restores them. And I do not know what is causing this to happen.

Here is the debug log. Hopefully someone can find what the issue is. Hopefully I can figure out how to fix it from that point, unless someone else already knows

11:30:24 T:1971679776 NOTICE: Running on Unknown Linux Distribution 0.0, kernel: Linux ARM 32-bit version 3.14.36+ge2837c4

Not very usefull Wink
There is one oddity about skin settings - they are not saved to disk until Kodi is quit using either the Power menu or via a JSON API call. If you're EzeeCube ever restarts Kodi by killing the process, that would nuke all your skin settings if you hadn't done a "safe" quit before then. So one thing to try is to do all the settings changes, quit Kodi by hand, and then start it again.
Thanks. I will give that a try and see if it resets at some point after that.

I tend to leave the EzeeCube on because I mapped the drive connected to it as a network drive.
So after setting everything up again and turning the EzeeCube off and then on, I have not had everything reset to default since then.
Nice to see you finally got this working again Smile
Thread marked solved.