Kodi Community Forum

Full Version: Downloading Kodi v 17 on chinese MXQ Pro issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I can no longer watch any movies on my box due to the old version on the box. I factory reset my box, went into apps, uninstalled Kodi. Went to the Browser within the Box and downloaded version 17 Kodi and tried to open it and no matter what version I downloaded it says it can't open. So I went under securities and allowed to download from unknown sources. Still doesn't open. Now I'm trying to be sneaky. I don't have a flash drive. I download it onto my computer, and email to myself. Go back to the box, open the browser, sign into email, open the drive. Now it's downloaded on the box, I need to install. It goes through the "installaion process" but then says " app not installed" What theHuh Now what do I do? Any suggestions?
How are you watching those movies? What is their source?
What Android version do you have?