Kodi Community Forum

Full Version: Pulse Eight CEC adapter does not work properly
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I'm using a Pulse Eight CEC adapter on my HTPC for Live TV (Kodi 17, DVB Viewer Recording Service, Windows 10 x64, Intel i5 4570, Geforce GTX 970) but it does not work properly. The HDMI cable is connected to an Onkyo TX-NR616 av-receiver and from there to a Samsung TV.

Generally, the CEC adapter (v4.0.1) is working with Kodi. But closing Kodi (for watching Amazon Prime, Netflix, playing games,...) results in switching off the av-receiver and the TV. Very annoying...

So I tried the libCEC tray tool (v4.0.2) for switching the av-receiver and the TV on/off together with the HTPC independent from Kodi. But libCEC does not work with Kodi 17 as only one instance can access the CEC adapter. I got it working by renaming Kodi to kodi1.exe and auto-starting the tray tool before Kodi starts. By starting the tray tool first Kodi cant access the adapter anymore.

Nevertheless, the usage of the CEC adapter results in weird behavior as randomly the TV switches on without any picture (even without Samsung's startup screen) and i need to disconnect the TV's power cord to get it working again.

I wrote two emails to Pulse Eight but their support seems to be pretty bad as my emails have been ignored.

How can I get rid of this annoying problem?
no advice?
I'm in the same boat as you are OP. My advice? Unplug the thing and toss it in the closet (or sell it some other unsuspecting sap on Ebay or something). I bought one and it caused nothing but issues with my HTPC+AVR. I'm not trying to come off as a jerk in responding to you but I thought it was going to solve some of my issues but it created more. Waste of $, IMHO.
The company won't even respond to tech support help either.
Good to hear I'm not the only one with these problems...
Yes pulse eight seems to have become very unfriendly to customers. Their forums have disappeared too.
sorry for reviving this thread, but i've been having issues with my cec adapter ever since i upgraded to the latest version of kodi
I've owned the pulse CEC adaptor for quite a while and only recently i've run into some problems. I'm laying down my setup for you in hopes that someone will be able to help out.

So i have a custom built htpc with a dedicated gpu running librelec for Kodi. out of the motherboard's HDMI port, i'm sending audio to my Denon AV receiver which is also connected on the hdmi arc port of my tv.
the pulse 8 CEC adapter is connected to the GPU hdmi port, and from the adapter i run an hdmi cable to my Samsung smart tv. So technically i'm using one port to drive just the AVR and one to send video to my tv, also with the CEC adapter on it so i can control my htpc through my tv's remote.
At first, i'd have just one hdmi port, connected with the cec adapter, sending audio and video straight to my avr. but i noticed that when i turned the system on, under the audio capabilities of my avr, there would be no options for DTS-HD or Dolby Atmos, thus i ended up running a dedicated hdmi port just for that.
Come 2019, kodi released its latest version, librelec upgraded its software and i'm having this issue (using the exact same setup and connections): when i turn my htpc, the tv goes straight to the avr channel. i get sound from my htpc and i control it with the tv's remote, but when i switch my tv back to the hdmi channel, i lose control of the cec adapter, even though it's listed properly in the system! even when i try to play a video, the tv switches back to the avr channel, getting audio but not video (since video is going to the tv's hdmi port i'm being switch out of).
any ideas or suggestions are welcome!
thanks in advance for taking the time to read my mess!