Kodi Community Forum

Full Version: Player interface - stuttering playback for random files in Kodi 17
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've read through and tried most of the suggestions in these posts about the same issue and have been troubleshooting and trying different things since the release of 17.0.

309240 (thread)
289498 (thread)
308554 (thread)
312925 (thread)
311468 (thread)
310007 (thread)

*************************************************************
Bringing up the player interface ( osd with play button etc) stops the stuttering
• Never had issues with these files in Kodi 16 - I have gone back and forth between Kodi 16 and 17 – only a problem in 17, including 17,17.1,17.2 and 17.3 – I have installed each new release and gone back to 16 each time due to the stuttering.
• The files play fine in all other players I’ve tried – VLC, windows Films and TV,Windows mediaplayer
• About 10 - 15% of files stutter
• Mp4 and mkv files are mostly what I use
• I use the emby plugin however the issue exists with or without emby.
• All files are stored on the same machine as the player so network is not a factor
• Installed Kodi to a new location on a new drive to see if portable would work - no change

Debug posted to https://paste.ubuntu.com/25254235

My Setup
• Windows 10 Home x64 fully updated – at time of writing – 1703 build 15063.483
• Memory: 8192MB RAM
• Processor: AMD Athlon™ II X2 250 Processor (2 CPUs), ~3.0GHz
• DirectX Version: DirectX 12
• OS on SSD, files stored on HDD
• Computer connected to TV via HDMI, sound through TV via HDMI also
• Addons used – Emby and Trakt
• Log file uploaded to https://paste.ubuntu.com/25254235
o Log file created by the following process – deleted log file, started kodi, enabled logging, exited kodi, started kodi, started tv show that has the issue, ran for approx 10 seconds, then disabled logging and uploaded log file using kodi log file uploader addin.


Suggested fixes I’ve seen and tried to no avail
• Power plan set to best performance – already was
• Graphics – ATI Radeon HD 4200 has the latest available drivers, downloaded ATI tool and ran to be sure.
• DXVA – stutters whether on or off, it was on, turned off, restarted KODI, retried video, still the same.
• sound settings are set to WASAPI and not DirectSound ( tried all Wasapi options ) – They were on DirectSound by default. - no change
• uninstalled kodi completely including deleting profile folder, then installed 17.3 to a new location, added only one tv folder with a known stuttering file – still stutters if the osd isn’t showing. Doesn’t stutter once the OSD is displayed.
• trying to play x265/hevc encoded movies not supported by graphics driver – not x265 that are having the issue. Files play in vlc and kodi 16, so not an “unsupported by graphics driver” issue.
• change from "fullscreen" to "windowed mode" – same either way
• the most effective way to stop stuttering was and still is to trigger the Playercodecinfo-display ON with CTRL-SHIFT-O – no effect
• settings>player>videos>sync playback to display (toggled off) Change sync playback to off – tried both on and off, no change
• Settings/Player/Videos : Adjust display refresh rate: Off
• Change the renderer to “pixel shader” – tried all the options in here – no change
• Settings/Player/Videos : You are attempting to Hardware decode videos (that is what DXVA is doing). Change this to Software mode – as above, tried all the options, no change.
• Settings/system Settings/display (advanced) – number of graphics buffers should be set to two – tried both two and three, no change.
• Settings / System Settings Audio/output configuration - change Optimized to Best Match – tried all the options here – no change
• change the mode on the adapter to [email protected] - Windows button, type “Display” choose “change display settings” – select “display adapter properties” – “Monitor” tab, change screen refresh rate to 60Hz or 59Hz – try the other one to what you currently have – I was able to set to 59 or 60Hz here, however in the AMD vision engine control center, if I chose 1080p, it would not allow me to change it to 59Hz

************************************this is the output of mediainfo for a problematic file**************************
Format : Matroska
Format version : Version 4 / Version 2
File size : 323 MiB
Duration : 43 min 10 s
Overall bit rate : 1 046 kb/s
Encoded date : UTC 2017-07-22 01:14:18
Writing application : mkvmerge v8.8.0 ('Wind at my back') 64bit
Writing library : libebml v1.3.3 + libmatroska v1.4.4

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : [email protected]
Format settings, CABAC : Yes
Format settings, RefFrames : 4 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 43 min 10 s
Bit rate : 915 kb/s
Width : 960 pixels
Height : 540 pixels
Display aspect ratio : 16:9
Frame rate mode : Variable
Frame rate : 23.976 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.074
Stream size : 283 MiB (87%)
Writing library : x264 core 148
Encoding settings : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x1:0x111 / me=umh / subme=10 / psy=1 / psy_rd=1.00:0.15 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-3 / threads=10 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=0 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=48 / keyint_min=4 / scenecut=0 / intra_refresh=0 / rc_lookahead=48 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.75 / qpmin=10 / qpmax=51 / qpstep=4 / vbv_maxrate=2000 / vbv_bufsize=4000 / crf_max=0.0 / nal_hrd=none / filler=0 / ip_ratio=1.40 / aq=1:0.80
Default : Yes
Forced : No

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : A_AAC
Duration : 43 min 10 s
Bit rate : 128 kb/s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 39.5 MiB (12%)
Default : Yes
Forced : No

********************************************************************************************************************


If at the end of the day, the 17 player interface has a higher spec requirement than my PC is capable of, fair enough, just let me know and I'll have to live with KODI 16 till I can afford to buy a new media center PC, but if you have any way to keep me on 17, I'd like to know.

alternately, if there is a hardware component that is stopping me using KODI 17, let me know the minimum requirements of the component you think it might be, maybe a small purchase will be enough to get me up and running.

Thanks for any info you can provide.
woohoo, as is always the way, months of troubleshooting and suddenly as soon as I ask for help, stuff just starts working.

to help anyone else with the stuttering issue, below are the settings I was playing with and what those settings are now (working)

if you are having problems and have a similar setup to mine, maybe replicate this with your setup, restart KODI and see how it goes. Just good to know it is nothing to do with my media center, from reading many posts about this stuttering issue, it has become apparent that you just have to have KODI configured with whatever works for your setup to have the player function.
It may be as I found out that it appears that it may be a combination of settings too. For me, each of these settings individually didn't work, it wasn't till I found the right combination that the stutter disappeared. I still don't know which particular settings are the ones that stopped the stutter, but all of these settings are mentioned somewhere in these forums as suggestions for stopping the stutter and many people have had the stuttering stopped by modifying at least one of these settings. Good Luck if you have this issue and I hope something here helps you solve it.

Settings – system – display – display mode – FullScreen
Settings – system – display – Use full screen window - off
Settings – system – display – number of buffers used by graphics driver – 2
Settings – system – Audio – directsound HDMI (Wasapi also fine, but computer audio controls don’t work with Wasapi enabled
Settings – system – Audio – Output configuration - Fixed
Settings –Player – Videos – adjust display refresh rate - off
Settings –Player – Videos – Sync Playback to display – off
Settings –Player – Videos – Allow hardware acceleration - DXVA2
Settings –Player – Videos – Render Method – Software

When you play a video, there is another settings option on the bottom right of the OSD, these are the settings I set in there.
Video settings – Deinterlace method – DXVA
Video settings – Video Scaling method – Bicubic (not sure if this one was relevant, but included anyway)
Audio and subtitle settings – Allow passthrough – disabled


if this doesn't fix it for you, maybe go through the settings in my first post to see if one of the ones I haven't included here might help you - update graphics drivers, set power plan to high performance etc.
Disable anti virus on the router, change resolution to 1920x1080P
@peakay great self-diagnosis and thank-you for coming back with your resolve, hopefully this will help others.
Are you kidding ? Where is most terrible settings I ever seen.