Kodi Community Forum

Full Version: Kodi 17, Intel NUC, Ubuntu 17 - juddery playback
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Currently having strange video playback issues with various formats from SD, to 1080p. Video appears to judder and look unnatural when scenes scan.

As a little background, this was usually fixed on my previous system (Acer Revo with NVIDIA ION running Windows 7) by turning "use fullscreen window" to OFF. This appears to be a Windows only setting as I cannot find it on my current setup which is running Ubuntu. One thing I have done which has marginally improved performance is turn off bitstream audio (which is a shame as it's something I would like to be switched on).

Is this something that's been seen before, or is there anything recommended I can do to solve this? It's a little powerhouse this NUC and I'm a little disappointed I can't get smooth video playback any more.

Just as a side note, I did try other settings such as syncing playback to display but this didn't seem to do much either apart from disrupt everything when starting the playback.

Any input greatly appreciated.

Thanks
This may have more to do with video drivers, then Kodi settings. A proper debug with logging turned on posted to a public pastebin and that URL linked back to this thread; will help to diagnose this, along with the file type you are trying to play (mediainfo posted here).

271868 (thread)
Change the resolution to 1920x1080p @ 50hz and see fi that helps
(2017-08-09, 19:13)venomxx Wrote: [ -> ]Change the resolution to 1920x1080p @ 50hz and see fi that helps

Is this a cmd line operation? I can't find it in the GUI. I found on google something about xrandr but couldn't get the command to force 50hz
xrandr -r 50
(2017-08-09, 20:34)fritsch Wrote: [ -> ]xrandr -r 50

great thanks, this looks to have made a difference.

Regarding drivers, is there any particular version I should be using for my NUC?
looks like i'm missing something?

VDPAU::Open: required extension GL_NV_vdpau_interop not found
I can only speak for myself using my android box, i don't know anything about linux but if you find out how to change the resolution to 1920x1080p @ 50hz you should be good to go.

The other thing is go into player settings and make sure hardware acceleration ( surface ) is turned on..

good luck
(2017-08-11, 00:42)venomxx Wrote: [ -> ]I can only speak for myself using my android box, i don't know anything about linux but if you find out how to change the resolution to 1920x1080p @ 50hz you should be good to go.

The other thing is go into player settings and make sure hardware acceleration ( surface ) is turned on..

good luck
That won't help you for android _at all_
(2017-08-11, 23:29)fritsch Wrote: [ -> ]
(2017-08-11, 00:42)venomxx Wrote: [ -> ]I can only speak for myself using my android box, i don't know anything about linux but if you find out how to change the resolution to 1920x1080p @ 50hz you should be good to go.

The other thing is go into player settings and make sure hardware acceleration ( surface ) is turned on..

good luck
That won't help you for android _at all_

Well yes it did, i had mad stuttering until i changed the resolution to 1920x1080p @ 50hz
What I said was: If he finds out on how to change refreshrate in linux, that won't help you at all for android. Cause it's different there.

But good that it works now for you. As it seems that Adjust Refreshrate is not working for you I'd "just" enable Sync Playback to Display so that other content won't be harmed.