Kodi Community Forum

Full Version: Linux - SMB DVD Playback no longer works
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Running Lubuntu 16.04. Intel x84. Intel Video. Output to HDMI. DVD library in on a SMB share. DVD's are in folders in original DVD file format, region encoding removed.

I was running Kodi 16.1. All my DVD's were playing back perfectly. Tonight I decided to do the Upgrade to 17.4. Now when I attempt to play a DVD from the SMB share I get the "One or more items failed..." error message. DVD's are included in the Movies Section. Running the Confluence Skin.

Playback works perfectly on the Mac and Android versions of Kodi 17.4 for these SMB shared DVDs.

Kodi log for when I try and play a DVD is here: https://pastebin.com/raw/ZhhV2PYr

One extra bit of information. BluRays stored at the same SMB share play just fine.
1st: That is not a kodi.log file. That is just a snippet which you think is interesting. Upload full logs in the future.

2nd: Check the SMB version of your systems. Due to the whole worldwide WannaCry debacle, systems are moving on to SMBv2 and higher. SMBv1 is deemed a critical danger.
My apologies. I have added a full debug log this time at: https://pastebin.com/q2fC8249

The NAS that hosts this files is old and technically does allow smbv2, but I'm not sure what it defaults to.

However, having said that, having the shares as folders in "Videos" I can navigate to the DVD folder, into the VIDEO_TS folder and can play various .vob file directly from here. Also the Jodi 17.4 installs on my Mac, Android and Windows 10 devices can all play the DVDs just file.

I can also play normal (.avi, .mpg, mkv,...) files from these shares.

Hopefully this information helps. Thanks in advance for any help you can provide.
Looks like you are trying to open a DVD folder. You have to play a full udf DVD ISO file instead.
Currently each DVD folder contains the VIDEO_TS, AUDIO_TS, folder.jpg and the movies .nfo information file. Nothing in the AUDIO_TS folder usually, and all the video type files are in the VIDEO_TS folder. So it is essentially the same layout as a DVD disk.

I have tried to play the DVD from the root directory of the DVD and by selecting play on the VIDEO_TS folder, but have the same result.

This has worked in previous versions of kodi and it works on all the non-linux versions. Has something suddenly changed with the implementation that I can now only play ISO files?
This is the full debug kodi.log from windows playing the same DVD at the same path/location: https://pastebin.com/tx5C6ndq
I've rolled it back to Kodi 16.1 and DVDs are playing just fine again


I just did a fresh install of Lubuntu 16.04 on a new computer. Installed Kodi 17.4 and added the DVD folder as a source, and the same issue exists on this new computer.
Can't test as we currently have a power cut.
Were you able to re-produce this issue?
Yes I think so, but I'll do some more testing.