Kodi Community Forum

Full Version: Kodi Forum : Report forum issues here
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
Is it possible to have a thread display as unread (ie: bolded) if the last(?) post has been edited since the last post was created? I'm specifically eyeballing the XBox One Known Issues sticky. Since the thread was created on 2017-12-30, there have been several edits and I was thinking bolding it might help draw attention to the new info provided within.

BTW Thanks to @ronie, @Kib, and everyone else working on the forum modifications. This latest version of the Kodi forum is by far the easiest forum to navigate that I've come across.
nah, there's no option for that.

only found a plugin that monitors the last post in a thread for changes, and marks the thread as unread.
but there don't seem to be anything that handles all posts in a thread.

tbh, editing a post to add relevant info shouldn't be done imo (except for the first post),
it's better just to post a new reply.
(2018-01-23, 20:23)nikstra Wrote: [ -> ]It seems to be some kind of permission issue with the board statistics at the bottom of the forum start page. It is not displayed correctly below Board Statistics / Who's Online when I'm logged out.

When I am logged out:

Users online:
Please welcome our newest member, XXXXXX
{1} {2} active in the past {3} minutes ({4} {5}, {6} of whom {7} invisible, and {8} {9}).

thanx, that bit should be hidden indeed when not logged in.
easy to fix, but i'll wait a bit with making new changes until i've updated the forum software to the latest version.
Possible to make clicking on the thread title go to the 'last unread post' rather than the 'first post' on the thread subscription page?

https://forum.kodi.tv/usercp.php?action=subscriptions

I know you can click the little arrow but its quite hard to select.
nope, not as easy as flipping a switch in the forum config.
You can just click on the link 'Last Post' to go there, or am I missing something ?
Perhaps we need a Forum Tips & Tricks thread somewhere.
no idea if it's a tip or a trick, but for the unaware:
arrow in front of the thread subject = go to first unread post in the thread
last post link = go to the last post in the thread
bugreport to self:

Image

usercp > subscriptions
I don't see that @ronie , maybe this is only in your dev environment ?
(2018-01-24, 12:25)Kib Wrote: [ -> ]You can just click on the link 'Last Post' to go there, or am I missing something ?
 No thread pages in sub view, but you can click the little arrow at the front of the thread title. But its so teeny tiny Smile

Image

But the old forum let you click on the thread title and it went automatically to the most recent unread post.

It's just habit I guess.
(2018-01-24, 12:55)ronie Wrote: [ -> ]bugreport to self:

Image

usercp > subscriptions
 thx for the report ronie, i have fixed it for you.
(2018-01-23, 20:23)nikstra Wrote: [ -> ]It seems to be some kind of permission issue with the board statistics at the bottom of the forum start page. It is not displayed correctly below Board Statistics / Who's Online when I'm logged out.

When I am logged out:

Users online:
Please welcome our newest member, XXXXXX
{1} {2} active in the past {3} minutes ({4} {5}, {6} of whom {7} invisible, and {8} {9}).


When I am logged in:

Users online: <long list of users>
Please welcome our newest member, XXXXXX
2,970 users active in the past 60 minutes (380 members, 29 of whom are invisible, and 2,584 guests).
 thx, should be fixed now.
(2018-01-27, 17:11)ronie Wrote: [ -> ] thx, should be fixed now. 
Yes, it looks good.
Just noticed a small issue with the following message content (can't really post it here, so using pastebin: https://pastebin.com/raw/9F5zQy1R)

Depending on how you post (or subsequently edit) this content, you'll see different results.

1. Paste content into "Quick Reply" box and click "Post Reply" -> https://screenshots.firefox.com/t45M0QQV...um.kodi.tv
2. Click "New Reply", paste content and click "Post Reply" -> https://screenshots.firefox.com/OmqcfIwY...um.kodi.tv
3. "Quick Edit" message created by #2 and click "Save Changes" -> https://screenshots.firefox.com/t45M0QQV...um.kodi.tv
4. "Full Edit" any message created by #1/#2/#3 and click "Update Post" -> https://screenshots.firefox.com/OmqcfIwY...um.kodi.tv

1 & 3 are incorrect.
2 & 4 are correct.

In other words, "Quick Reply" and "Quick Edit" both result in double spacing of [syntax] text.

Edit: This may be some sort of caching or browser issue (testing with Firefox 58.0 on Windows). After 1 & 4 the syntax text is incorrect, but if the window is refreshed with Ctrl-R the message is formatted correctly. Will test with Chrome...

Edit2: Chrome has the same issue. I did a "Quick Edit" on this message and clicked on "Save Changes" and this is how the message looked in the Chrome Window:
Image

I then entered Ctrl-R to refresh the window, and the message changed to:
Image
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36