Kodi Community Forum

Full Version: Blinking overlays in video player
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm running Kodi on Ubuntu 17.10 and I have the strangest problem.  Everything works perfectly - video is right, audio, everything.  However, whenever a video overlay comes up including the info screen in video player or subtitles, the overlay part blinks (tears?) like crazy.

This started only after the upgrade from Ubuntu 17.04 - 17.10 but nothing else changed.  I've tried multiple versions of Kodi and it happens on all of them.  Any ideas what to check?

I'm using the Ubuntu repository:  ppa:team-xbmc/ppa
kodi         2:17.5+git2017102 all
kodi-bin   2:17.5+git2017102 amd64

And from the log:
09:18:55.269 T:140427599575424  NOTICE: GL_RENDERER = AMD CAICOS (DRM 2.50.0 / 4.13.0-041300-generic, LLVM 5.0.0)
09:18:55.269 T:140427599575424  NOTICE: GL_VERSION = 3.0 Mesa 17.2.2

Also, and hopefully not related, what's up with the dates on kodi-bin?
09:18:55.125 T:140427599575424  NOTICE: Starting Kodi (17.5 Git:20121104-5bd45ab). Platform: Linux x86 64-bit
09:18:55.125 T:140427599575424  NOTICE: Using Release Kodi x64 build
09:18:55.125 T:140427599575424  NOTICE: Kodi compiled Nov  4 2012 by GCC 7.2.0 for Linux x86 64-bit version 4.13.4 (265476)
09:18:55.125 T:140427599575424  NOTICE: Running on Ubuntu 17.10, kernel: Linux x86 64-bit version 4.13.0-041300-generic

I just uninstall and reinstalled and this is what gets put back:
-rwxr-xr-x 1 root root 42024272 Nov  4  2012 /usr/lib/x86_64-linux-gnu/kodi/kodi.bin*

Edit: Full debug log: https://pastebin.com/ugyzSUi2
If you're seeking assistance please provide a link to your FULL Debug log (wiki) via pastebin or similar, no snippets.
(2017-11-14, 16:35)Dangelus Wrote: [ -> ]If you're seeking assistance please provide a link to your FULL Debug log (wiki) via pastebin or similar, no snippets.

Edited the original to have the full log: https://pastebin.com/ugyzSUi2
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
(2017-11-14, 17:25)Dangelus Wrote: [ -> ]The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.

New log after deleting every addon that isn't default kodi:  https://pastebin.com/fVkinAfx
Same here, also 17.10 + AMD video card.
(2018-01-30, 02:13)jchonc Wrote: [ -> ]Same here, also 17.10 + AMD video card.
Driver-bug in AMD OSS video driver. You can try if the OpenGL 4 path is working for you: MESA_GL_VERSION_OVERRIDE=4.0 kodi

Edit: That won't work. You are running XWayland. Please update to kodi-wayland from kodi's nightly ppa
Quote:12:59:12.890 T:139898041227648    INFO: Output 'XWAYLAND0' has 1 modes12:59:12.890 T:139898041227648    INFO: ID:0x22 Name:1920x1080 Refresh:59.962841 Width:1920 Height:1080 12:59:12.890 T:139898041227648    INFO: Pixel Ratio: 1.000919