Kodi Community Forum

Full Version: Tonight's Build (Rev.12482) Loads but stays at a black screen.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
It shows the XBMC logo, then goes to a black screen and sits like it's frozen.

http://pastebin.com/f7d6322e3
D4rk introduced a common profile handling for all three ports. Platform dependent paths can be activated by passing -p on the command line. Without -p it uses the XBMC binary directory for all things. I have to remove the second mapping of T: because this is what causes you problems.
Anyhow cleaning your profile will have the same effect Wink
WiSo Wrote:D4rk introduced a common profile handling for all three ports. Platform dependent paths can be activated by passing -p on the command line. Without -p it uses the XBMC binary directory for all things. I have to remove the second mapping of T: because this is what causes you problems.
Anyhow cleaning your profile will have the same effect Wink

Could you give an example of the command line argument?

Thanks
mmh there's a little more broken. Have to check it.
So fixed in recent svn. Command line options are -p for platform directories (user\App Data\XBMC), -q for quite mode and -fs for fullscreen.
And the build can be downloaded from? Smile

DP
Source? From the SVN repository. Currently nowhere for self compiled versions like djdafreund's.
I know CI that it's nowhere to download. I was rather poking with my finger at WiSo (doing great job BTW). I was wondering if building some kind of weekly win32 build would be a big hassle. I tried to build myself but I am totally lost in developing, I am more like a infrastructure guy. Is it big PITA to buld win32 port now? If it is - I can understand that we gonna get win32 builds once in a few weeks. If it's not - some kind of regular build schedule would be beneficial for development of the linux/win32 port. I would do it, but I am lame ass in dev enviroments as I said before Smile


DP
It was actually freezing when using -p actually, but it sounds like something was fixed since then in the SVN. So i'll build another one in a minute and run it again. Thanks.
As far as regular builds, i wouldn't mind uploading mine to a designated acceptable place for others, so more users can help troubleshoot and debug stuff. I build them every other day or more anyway.
I'd still like to get help on a Build.bat compatible file, like you can build for the DX version, instead of having to load up VC2003 and 'Build XBMC', then also use Build.bat/PC DX version to get the updated XBMC directory files. Currently it gives an error when trying to run the original Build.bat due to some files not being found. I'm not good enough with that area to fix it for proper usage.

WOW what a massive list of SVN updates for 04-05-08!!!! Nice to see!!!!

Update- Yes, it's working again now (using '-p' of course)!!! Thanks for the fixes. That did the trick.
WiSo Wrote:So fixed in recent svn. Command line options are -p for platform directories (user\App Data\XBMC), -q for quite mode and -fs for fullscreen.

What do I need to put in (user\App Data\XBMC) for XBMC to recognize the layout for the drives in my computer?

Thanks
djdafreund Wrote:I'd still like to get help on a Build.bat compatible file, like you can build for the DX version, instead of having to load up VC2003 and 'Build XBMC', then also use Build.bat/PC DX version to get the updated XBMC directory files. Currently it gives an error when trying to run the original Build.bat due to some files not being found. I'm not good enough with that area to fix it for proper usage.
Build.bat is fixed for the SDL build. Feel free to compile regular builds but respect the svn changelog to inform people about bigger changes (like the profile change via command line).
OK, noob to this lark. I have XBMC running fine but I thought I'd try and keep up to date with SVN so installed VS .Net 2003 on Vista 32-bit but whenever I load the tools\Win32\XBMC_PC.vcproj I get the error:-

xbmc\lib\UnrarXLib\UnrarXLib.vcproj failed to open. Have I confgured something wrong? This is the only project out of the 4 that fails to open.
Very nice!!! Thanks SO much!!! I don't mind releasing Un-Official builds since i made them almost daily anyway, where could be a good spot to upload it to? Rapidshare acceptable within the terms? Or possible to give some access for me to upload to Sourceforge site? I would keep all the proper files in tact with mentioning it's not Officially supported, and also i would include the Back-Row skin as well.

2 things i noticed after building it using the Build.bat, an SVN error in my SVN directory under D:\XBMC SDL\skin\Project Mayhem III\media\ (after refreshing the SVN, it looks like the Textures.xpr file is getting deleted, an easy fix by refreshing that directory again, but something in the Build.bat that can correct this?

Other thing, it says "Can't Find \tools\Win32\Release (SDL)\xbmc.exe" in the progression log(CMD window), but the file IS inside the directory, maybe the Build.bat file directory pointing is wrong? I can try looking to double-check i guess. But the rar'd file DOES have the xbmc.exe inside properly, as well as the BUILD_WIN32\Xbmc\xbmc.exe is there, so maybe this message isn't anything to worry about after all??
a "del ...\texture.xpr" should solve the first problem. Not sure about the second one because I can't remember seeing it on my PC.
Pages: 1 2