Kodi Community Forum

Full Version: Kodi won't play anything
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Tried to get help in the Windows section but it was suggested I try here. 

Weird issue. When I click play on a movie the progress bar says 100 in the middle of the screen and then fades out and it's nothing but a black screen while the time advances on the movie. The same thing happens with streaming content, it will show the first frame and 100 buffered and then nothing more. And even stranger the same thing happens with music, it looks like it's playing but the bar doesn't advance. Also when I go to shut down, exit, or reboot the PC freezes. Video plays fine through Windows. A complete Windows reinstall fixed the issue last time it happened, but it's back again.

I changed the name of my %appdata% folder and tried to play something to create a log:

https://pastebin.com/PCtTzTSx

Hoping someone might be able to shed some light on what's causing this. Thanks everyone for your help.
Little bit hard to tell what is happening at startup as you did not restart Kodi when you enabled debugging. We need it restarted so we can see what is being loaded.

But this did stand out...

Quote:20:23:39.500 T:1236 ERROR: CAESinkDirectSound::Initialize: Failed to create the DirectSound device VSX-820 (2- High Definition Audio Device) with error unknown, trying the default device.
20:23:39.544 T:1236 ERROR: CAESinkDirectSound::CheckPlayStatus: Failed to play the DirectSound buffer: unknown

Maybe fixing the audio component will rectify the video component. At least it is a first step.
1. Please turn debugging on THEN restart Kodi, then play your file. 

2. Please update to the current version of Kodi, ie 17.6.
Upgraded to 17.6. Turned on debugging before starting Kodi:

https://pastebin.com/m3pRQGFv