Kodi Community Forum

Full Version: Google Drive for KODI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, I just upgraded from Leia to Matrix on my Windows 10 PC. I am using the latest version of the Google Drive addon (1.4.10+matrix.2) as well as common cloud drive module (1.3.9+matrix.2). The Google Drive addon was working perfectly in Leia, but now it does not work in Matrix - "Error - Please check the log for more details". I tried installing the addon manually using zip file as well as through the official Kodi repository, but it does not work in both cases.

In the log file, this is the error that I am getting-

1-03-01 06:19:51.960 T:13944   ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'ModuleNotFoundError'>
                                                   Error Contents: No module named 'socketserver'
                                                   Traceback (most recent call last):
                                                     File "C:\Users\Areeb Rahman\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\service.py", line 20, in <module>
                                                       from clouddrive.common.service.source import SourceRedirector, SourceService
                                                     File "C:\Users\Areeb Rahman\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\service\source.py", line 30, in <module>
                                                       from clouddrive.common.service.base import BaseServerService, BaseHandler
                                                     File "C:\Users\Areeb Rahman\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\service\base.py", line 21, in <module>
                                                       from http.server import BaseHTTPRequestHandler
                                                     File "C:\Program Files\Kodi\system\python\Lib\http\server.py", line 102, in <module>
                                                       import socketserver
                                                   ModuleNotFoundError: No module named 'socketserver'
                                                   -->End of Python script error report<--
                                                   
2021-03-01 06:19:51.994 T:13944    INFO <general>: Python interpreter stopped
2021-03-01 06:19:51.999 T:14020    INFO <general>: [ script.embuary.helper ] Service: Started
2021-03-01 06:19:51.999 T:14020    INFO <general>: [ script.embuary.helper ] Service: Player monitor started
2021-03-01 06:19:52.000 T:12400   ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'ModuleNotFoundError'>
                                                   Error Contents: No module named 'socketserver'
                                                   Traceback (most recent call last):
                                                     File "C:\Users\Areeb Rahman\AppData\Roaming\Kodi\addons\plugin.googledrive\service.py", line 20, in <module>
                                                       from clouddrive.common.service.download import DownloadService
                                                     File "C:\Users\Areeb Rahman\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\service\download.py", line 23, in <module>
                                                       from clouddrive.common.service.base import BaseServerService, BaseHandler
                                                     File "C:\Users\Areeb Rahman\AppData\Roaming\Kodi\addons\script.module.clouddrive.common\clouddrive\common\service\base.py", line 21, in <module>
                                                       from http.server import BaseHTTPRequestHandler
                                                     File "C:\Program Files\Kodi\system\python\Lib\http\server.py", line 102, in <module>
                                                       import socketserver
                                                   ModuleNotFoundError: No module named 'socketserver'
                                                   -->End of Python script error report<--

Please let me know how to resolve this issue.
@areebiimi

I have moved you to the correct thread.
(2021-03-01, 04:00)Karellen Wrote: [ -> ]@areebiimi

I have moved you to the correct thread.

Thank you, Karellen

I look forward to receiving inputs about the issue
(2021-02-23, 13:27)AshipaEk0 Wrote: [ -> ]Does anyone have an idea of what sort of files i need to get the addon to let me stream in various formats/resolution?

When i tried the addon for the first time a while ago it would ask me to choose my preferred resolution.

Now it doesn't at all, it just plays the original.

I ticked the option to get it to ask in the addon settings but it never gives me the option anymore

does this have anything to do with the files themselves?   what type of file/encoding should i aim for to get this.  its very important and useful to me because of bandwidth and data caps
Same here.

Since Kodi 19 Matrix, the addon doesn't ask for a preferred resolution anymore.
I uninstalled the addon and re-installed.
I even re-installed Kodi (on my PC, to test).
Hi, I just installed a fresh build of Kodi 19.0 Matrix on my Windows 10 PC. Local videos are playing perfectly. However, whenever I play a video stored in my Google Drive using cguZZman's Google Drive addon, the video starts normally, but after 5 to 10 seconds, it freezes, although the mouse pointer keeps functioning. After that, if I click on stop video, Kodi stops responding and I have to force exit it. 
This is what comes up in the log file - CVideoPlayerAudio :: Process - stream stalled. I have an optical fiber connection, so internet speed is not the issue. And this issue is happening with all the videos stored in my Google Drive, even the small-sized low-bitrate ones.
Also, the Google Drive addon was working perfectly in Kodi Leia.
Please let me know how to fix this.
(2021-03-03, 03:55)areebiimi Wrote: [ -> ]Hi, I just installed a fresh build of Kodi 19.0 Matrix on my Windows 10 PC. Local videos are playing perfectly. However, whenever I play a video stored in my Google Drive using cguZZman's Google Drive addon, the video starts normally, but after 5 to 10 seconds, it freezes, although the mouse pointer keeps functioning. After that, if I click on stop video, Kodi stops responding and I have to force exit it. 
This is what comes up in the log file - CVideoPlayerAudio :: Process - stream stalled. I have an optical fiber connection, so internet speed is not the issue. And this issue is happening with all the videos stored in my Google Drive, even the small-sized low-bitrate ones.
Also, the Google Drive addon was working perfectly in Kodi Leia.
Please let me know how to fix this.

same prob here
Installed Google Drive on my Shield with Kodi 19.I can watch video files but cannot view any other files, photos documents etc.The folders are there but nothing shows up when opening any of them.Is there something else I need or settings to be changed to allow me to do so ?
(2021-03-03, 03:55)areebiimi Wrote: [ -> ]Hi, I just installed a fresh build of Kodi 19.0 Matrix on my Windows 10 PC. Local videos are playing perfectly. However, whenever I play a video stored in my Google Drive using cguZZman's Google Drive addon, the video starts normally, but after 5 to 10 seconds, it freezes, although the mouse pointer keeps functioning. After that, if I click on stop video, Kodi stops responding and I have to force exit it. 
This is what comes up in the log file - CVideoPlayerAudio :: Process - stream stalled. I have an optical fiber connection, so internet speed is not the issue. And this issue is happening with all the videos stored in my Google Drive, even the small-sized low-bitrate ones.
Also, the Google Drive addon was working perfectly in Kodi Leia.
Please let me know how to fix this.

Here's the full log- https://paste.kodi.tv/oqiqehivaw.kodi

Hope this will help resolve the issue.
(2021-03-03, 03:55)areebiimi Wrote: [ -> ]Hi, I just installed a fresh build of Kodi 19.0 Matrix on my Windows 10 PC. Local videos are playing perfectly. However, whenever I play a video stored in my Google Drive using cguZZman's Google Drive addon, the video starts normally, but after 5 to 10 seconds, it freezes, although the mouse pointer keeps functioning. After that, if I click on stop video, Kodi stops responding and I have to force exit it. 
This is what comes up in the log file - CVideoPlayerAudio :: Process - stream stalled. I have an optical fiber connection, so internet speed is not the issue. And this issue is happening with all the videos stored in my Google Drive, even the small-sized low-bitrate ones.
Also, the Google Drive addon was working perfectly in Kodi Leia.
Please let me know how to fix this.
Having the same issues on Android. Files start then freeze.
I need a log file with debug info to check any issue.
(2021-03-08, 16:51)cguZZMan Wrote: [ -> ]I need a log file with debug info to check any issue.

Hi @cguZZMan , as requested, kindly find below the full log with debug info-

https://paste.kodi.tv/ojunukikax.kodi

This is the issue I am facing-

I just installed a fresh build of Kodi 19.0 Matrix on my Windows 10 PC. Local videos are playing perfectly. However, whenever I play a video stored in my Google Drive using cguZZman's Google Drive addon, the video starts normally, but after 5 to 10 seconds, it freezes, although the mouse pointer keeps functioning. After that, if I click on "stop video", Kodi stops responding and I have to force exit it using task manager. I have an optical fiber connection, so internet speed is not the issue. And this issue is happening with all the videos stored in my Google Drive, even the small-sized low-bitrate ones.
Also, the Google Drive addon was working PERFECTLY in Kodi 18.9 Leia.
Please let me know how to fix this.
That seems like a Kodi issue. Not the addon. Check the following issue https://github.com/xbmc/xbmc/issues/19175
Maybe is the same scenario and there is a solution there.
(2021-03-12, 19:17)cguZZMan Wrote: [ -> ]That seems like a Kodi issue. Not the addon. Check the following issue https://github.com/xbmc/xbmc/issues/19175
Maybe is the same scenario and there is a solution there.

Hi @cguZZMan , you're a lifesaver!
Just had to add the following lines in advancedsettings.xml-

  <network>
    <disablehttp2>true</disablehttp2> 
  </network>

It is now working perfectly! Cannot thank you enough for your help!
I just installed the plugin and I'm trying to add an account. I scan the QR code on my mobile and proceed to enter the string of numbers and letters, triple checked for accuracy, but am told that the code is incorrect. I've tried it five times now, from the top, but it's the same every time.

How is this even possible?
Never mind. It worked from a PC.